TCCoA Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
505 Posts
Discussion Starter #1
I was told by the guys that installed my JBA's that my car might be running rich. Do I have to send my chip back to Dennis to get this corrected or is there something else I can do?
 

·
Refrigerator Raider Hater
Joined
·
11,719 Posts
Did you get the gen I or gen II chip?

If you got the gen I, skip this section. Did you reset the computer? install 22c plugs? install a 180deg T-stat?

Ok, now for both gens... have you replaced your primary o2 sensors? does the exhuast smell like gas? when did you last change/clean your air filter?
 

·
Registered
Joined
·
505 Posts
Discussion Starter #3
Did you get the gen I or gen II chip?
I got the chip from Dennis, there is no indication on the sheet of paper that he sent to me in the package, whether it is "Gen I or Gen II". How can I tell?

Did you reset the computer?
Yes, the battery was disconnected and then reconnected. Is there something else that should be done to reset it?

install 22c plugs?
Not sure. I had the shop that installed the MAF and Throttle body and exhaust system, also install the plugs. (I'll have to find out.)

install a 180deg T-stat?
No. ???

have you replaced your primary o2 sensors?
No. The cats were removed. I told Dennis this would be the case, and he programed the chip to not see them.

does the exhuast smell like gas?
Yes. And a strong carbon monoxide smell in the cabin.

when did you last change/clean your air filter?
@ 3000 Miles ago.

Any details you can provide about the things you asked would be appreciated, thanks.
 

·
Registered
Joined
·
443 Posts
carbon monoxide is an odorless gas...just thought i'd let you know...
 

·
Registered
Joined
·
505 Posts
Discussion Starter #5
I stand corrected

I guess I've always called the smell of exhaust, cabon monoxide, but as you said that is incorrect. With that being said, isn't it also true that carbon monoxide is a part of exhaust fumes?


Then the odor that I have coming in the cabin must be... unburnt fuel?!
 

·
Registered
Joined
·
970 Posts
Carbon Monoxide is not something you want coming out of your car. Carbon dioxide is a natural by product of combustion...but carbon monoxide isn't. Certain levels (next to nothing) are acceptable though. And it's true that it's odorless...but when an engine is running rich enough to produce lots of carbon monoxide...it produces other things that you can deffinately smell.

If your O2 sensors are old...replace em. Even though dennis tuned it to not worry about your cats...your motor still needs its "pre cat" or "primairy" O2 sensors. They are crucial to the EEC's A/F calculation. The ones he told the computer to ignore is your after-cat sensors which may or may not still be there since you had the cats removed.

I would talk to Dennis...cause it sounds to me like it's running pretty rich.

-danimal
 

·
Refrigerator Raider Hater
Joined
·
11,719 Posts
Find out which gen dennis sold you. gen II's NEED 22c plugs (possibly 12c, doubt that applies to you) and a 180deg t-stat.

you can reset the computer by disconnecting the battery for 5min (not sure the minimum) OR by pulling the EEC fuse in the "power distrobution box" under the hood.
 

·
Registered
Joined
·
505 Posts
Discussion Starter #8
I'll call Dennis tomorrow!

Thanks for the info guys. Hopefully between Dennis tweaking the chip, the 180 degree thermostat and 22c plugs, I'll get this problem taken care of.
 
1 - 8 of 8 Posts
Top