TCCoA Forums banner

1 - 1 of 1 Posts

·
Registered
Joined
·
48 Posts
Discussion Starter #1
Ok, my probs started when my car died on me and i coasted to a stop sign with only manual braking to stop me. I tried to start it to no avail, so I called the dreaded towtruck. I tried the put it in nuetral so I could get it out of the way and I couldnt get the shifter out of park. Tried a few more times and got it into nuetral and rolled it onto a sidestreeet. Towed it to the shop and it was a burnt up battery cable, so they took me to work and changed it. Stupid crap can't happen when I have time to change it myself. Anyway I go there to pick it up on my lunch hour and the car won't go anywhere, no matter what gear I put it in the engine just revs. Crap, I just had my tranny fixed, the bill said rebuilt TC, rebuild kit, new front pump, and some various other things, totalled to $1500, crap on me. So they got my car last wedneesday, and have had it since. The rebuild came with a 6 month/6,000 mile warranty on it, so therefore its a free fix, or atleast it better be. But they have not even touched it yet. I called just yesterday afternoon and they told me that they were getting ready to pull it in a bay and get it pulled out on Friday, and order the parts. Which every other time I called they told me they were getting ready to put it in a bay and look at it. So needless to say I am quite pissed at these ripoff, rude, lying, and non talented "mechanics." It was at a shop that does only trannies. All that they have told me was last Friday that the fluid was burnt and it was "Fubared." How great to hear. Also, my car is a '95 4.6L with 150K and about 3k and 2 months since tranny rebuild. So sorry bout my rant but my questions are, what do you guys think is wrong and what exactly can I do about this shop not fixing my car. My dad said he was going to stop by there today and find out what the heck is going on. Thanks in advance!!
 
1 - 1 of 1 Posts
Top