TCCoA Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
584 Posts
Discussion Starter #1
Jeez...that took 5 hours!! The ball joints DID NOT want to come out. On the driver's side I had to remove the caliper and disc and upper sway bar link connection to have a clear enough shot with a hammer to hit the ball joint thread....

Passenger side was almost as bad, I bought one of those ball joint removal tools...worthless...not wide enough to go around the bottom part of the ball joint. So it was remove the tie rod end from the power steering to be able to turn it enough to get a good shot with the hammer.

So now it's at Firestone getting an alignment.

My question is The rear bolt with the camber adjustment dials...they're both out of whack. Driving VERY slowly to Firestone it felt like driving on jello. Turn the wheel and it stayed turned. Turn a little to much and it whined like rubbing rubber... It also appears to be riding a little high. So I'm assuming the height can be adjusted by loosening the nut on that rear bolt which attaches the LCA to the subframe?

I'll pick it up tomorrow, I hope they can get it all lined up.

I did this in an attempt to quell some highway MPH vibration. Which is that, the driveshaft or the fan clutch...

Thanks amigos!
 

·
Premium Member
Joined
·
372 Posts
I don't have an answer to your alignment question, sorry. Just thought I would add in that you can use a front end service kit that makes separating the ball joint much easier. I have used it on a lot of different cars. Advance Auto usually has them in stock to rent. I fortunately haven't had to change the entire lower control arm; just pressed in new ball joints.
 

Attachments

·
Super Moderator
1994 Cougar XR7 DOHC/5-Speed
Joined
·
17,516 Posts
Alignment and suspension wear doesn't cause vibration, it's probably the driveshaft or wheel balance.

The LCA bolts will cause the front of the car to ride high if you tightened with the suspension drooped, the rubber effectively acts like a torsion bar (it'll wear out prematurely too). Once it's on the alignment rack though it'll be adjusted and tightened at rest. Same goes for the lower shock bolts and UCA bolts. You can collectively gain as much as an inch in ride height with all of those tightened at full droop.

You were hammering wrong. Don't hammer the threads when separating ball joints, smack the side of the spindle. The joint and spindle hole are machined tapered, and when you hit it hard enough the ball joint will be squeezed downward.
 

·
Registered
Joined
·
584 Posts
Discussion Starter #4 (Edited)
New LCA's had ball joints in them. I hammered the sides like crazy...nothing. Wheels have been balanced..twice. Vibration isn't always there, so I can't say for sure it's the drive shaft. My other idea is a 24 year old radiator fan clutch. I don't know what happens to it when it gets that old.
 

·
Registered
Joined
·
1,925 Posts
It's a good idea to mark the position of the alignment bolt and get it as close as possible when installing.

On the fan clutch - didn't we just do this in another thread? A guy replaced his and acted like it made it a new car again.

Al
 

·
Registered
Joined
·
584 Posts
Discussion Starter #6
It's a good idea to mark the position of the alignment bolt and get it as close as possible when installing.

On the fan clutch - didn't we just do this in another thread? A guy replaced his and acted like it made it a new car again.

Al

Yeah, that's on my list. Just need the wrench to get it off the shaft...

I didn't realize there were those circrular marked washers on the bolt. I knew I'd need an alignment so I just got it all back and slowly drove to Firestone. They'll finish it today some time.
 

·
Registered
Joined
·
584 Posts
Discussion Starter #7
got it back, much better. Less vibration too, but not all gone.

Did notice a puddle on the driveway of a clear thick'ish liquid...thought it might be brake fluid since I unhooked the passenger brake line. Nope that was dry. Looking under the car it was right around the bell housing and the engine. Going further up top I noticed it was from right around the rear of the passenger valve cover. A stream had formed...

Checking the liquid again I did the teeny taste test...it was sweet like sugar... but my antifreeze has a bitter agent in it and it's not any other fluid... Unless refrigerant oil tastes like honey. So I hosed it off, and this morning...dry.

Only think I can think of is some dummy at Firestone spilled his soda on it when looking at my engine...

I'll keep an eye on it....
 

·
Registered
Joined
·
584 Posts
Discussion Starter #8
NOPE, it was my broken cheap Chinese fuel pressure gauge on the fuel rail... it's full of a clear liquid (glycerin I'd assume), which leaked out and down the passenger side of the engine.

Easy fix!
 
1 - 8 of 8 Posts
Top