TCCoA Forums banner

1 - 10 of 10 Posts

·
Formerly Fdawg97LX
Joined
·
3,186 Posts
Discussion Starter #1
my car is throwing code P0605. I dont remember the explanation but the alldata cd says to fix it i need a new pcm. pcm is the same thing as eec, right? the injector for the #3 cylinder isnt receiving an electric pulse to make it work. what could have caused this. i just picked my car up after my pi cam install ordeal and this is how it was running. before the whole deal with the pi cams my car was running perfect. by the way the guy who fixed my car put the stock npi cams back in so i have just the pi intake on now with stock cams and stock heads if it matters. what could have cause my eec to go bad?

also are 96-97 computers interchangable?

Frank
 

·
Refrigerator Raider Hater
Joined
·
11,719 Posts
Yes, 96-97 may have different catch codes, but the pinouts and programs are all the same.

All code 605 means is that you have a chip. nothing is wrong with your EEC.
 

·
Formerly Fdawg97LX
Joined
·
3,186 Posts
Discussion Starter #3
GreenBird said:
Yes, 96-97 may have different catch codes, but the pinouts and programs are all the same.

All code 605 means is that you have a chip. nothing is wrong with your EEC.
0
why did my check engine light never come on before. i've had the chip since last july.

Frank
 

·
Refrigerator Raider Hater
Joined
·
11,719 Posts
Usually the chip turns off code 605....so maybe your chip has "lost" it's program, it does happen.
 

·
Formerly Fdawg97LX
Joined
·
3,186 Posts
Discussion Starter #5
So I pulled out the chip and the car still ran like crap. so i waited for my check engine light to come back on and wet to autozone to get the codes read. I got P0171 and P0174. Bank 1 and bank 2 to lean. is this something that could be caused by my injector that isnt working? i hope so.

Frank
 

·
Chapter Director Coordinator
Joined
·
6,253 Posts
well.. if the injector no working right..tht mean not enough fuel goin in cylinder.. so ya.. lean condition there..

does it NOT WORK or is it just dirty?
 

·
Formerly Fdawg97LX
Joined
·
3,186 Posts
Discussion Starter #7
jamesD said:
well.. if the injector no working right..tht mean not enough fuel goin in cylinder.. so ya.. lean condition there..

does it NOT WORK or is it just dirty?
its not recieving an electric pulse from the eec. i think there is a short somewhere.
now that i read your answer, i realize my question was kinda dumb, haha.

Frank
 

·
Registered
Joined
·
2,983 Posts
Mine had some cylinders running lean and it was bad O2 sensors. Im not saying thats the only reason to get that but it is a common thing to go bad on our cars.

good luck
 

·
Formerly Fdawg97LX
Joined
·
3,186 Posts
Discussion Starter #9
Shawn40th said:
Mine had some cylinders running lean and it was bad O2 sensors. Im not saying thats the only reason to get that but it is a common thing to go bad on our cars.

good luck
if i get my injector working and the code doesnt go away, thats what i will check next. thanks for the help.

Frank
 

·
Formerly Fdawg97LX
Joined
·
3,186 Posts
Discussion Starter #10
codes gone. one of the #3 injector wires was broken. got it fixed and the car is running great now. thanks for the help.

Frank
 
1 - 10 of 10 Posts
Top