TCCoA Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
748 Posts
Discussion Starter #1
On my '89 T-Bird SC, when I'm going foward and turning sharply either direction, I'm getting a "clunk" noise from the front end. I've replaced the radious arm bushings at the lower control arm, upper and lower ball joints on both sides and also put a set of Vogtland springs ( 3/4" drop) on as well.....all was done back in October of '08 and it's been doing it ever since. At first I thought it was the springs and front end settling but everything should be "good" by now.

Had the front jacked up last week trying to figure it out and inspect other parts like the tie rod ends and what have ya. Even turned the wheel all the way both directions and all I got was a slight clunk when the wheels were turned all the way over in both directions, but it was nothing like the clunk I get when she's on the ground and moving foward and turned almost all the way----in either direction.
Oh, and when she is turned almost all the way, she feels like she's pushing.

So I'm not sure what it could be......bushing bind up, something in the rack and pinion, something with the springs or new bushings, or what. Any ideas guys??

Thanks.
Slowride
 

·
Registered
Joined
·
401 Posts
Could be a number of things. I would recommend reading the sticky at the top of the suspension forum, if you haven't already.
 

·
Registered
Joined
·
3,902 Posts
Had the same problem on mine.check and make sure all the nuts and bolts are tight on the parts that attach your suspension to your body..Good luck..

Rayo..
X2 buddy, this has happened to me on my own car(my 92 cougar too) and some customers' cars
-Rob
 

·
Registered
Joined
·
1,170 Posts
On my '89 T-Bird SC, when I'm going foward and turning sharply either direction, I'm getting a "clunk" noise from the front end. I've replaced the radious arm bushings at the lower control arm, upper and lower ball joints on both sides and also put a set of Vogtland springs ( 3/4" drop) on as well.....all was done back in October of '08 and it's been doing it ever since. At first I thought it was the springs and front end settling but everything should be "good" by now.

Had the front jacked up last week trying to figure it out and inspect other parts like the tie rod ends and what have ya. Even turned the wheel all the way both directions and all I got was a slight clunk when the wheels were turned all the way over in both directions, but it was nothing like the clunk I get when she's on the ground and moving foward and turned almost all the way----in either direction.
Oh, and when she is turned almost all the way, she feels like she's pushing.

So I'm not sure what it could be......bushing bind up, something in the rack and pinion, something with the springs or new bushings, or what. Any ideas guys??

Thanks.
Slowride
hey check the stabilizer bar links. If the rubber is torn replace them.
 

·
Super Moderator
Joined
·
12,652 Posts

·
Registered
Joined
·
6 Posts
clunk

I had a pritty bad clunking/clatter and i grabed the upper control arm and made the noise!Just tightened up and went away!Not saying thats your problem but worth a try!
 

·
SuperNewbie
1995 Thunderbird LX 4.6 red
Joined
·
2,871 Posts
Check the anti sway bar endlinks..
 

·
Registered
Joined
·
154 Posts
supergordo, you hit it right on the money. I know that sound. When I went in for an oil change, I had the mechanics move my front end from side to side, making that clunking sound, while one was underneath the car trying to find the source of it. Turns out, it was the sway bar connecting links. They replaced them for about $200 total for both sides, clunking gone, and the car handles WAY bettter. Well worth the $200.
 

·
Registered
Joined
·
748 Posts
Discussion Starter #9
I'll recheck everything and go from there. It does kinda sound like the pivot bolts may be loose....I'll check.

Thanks !
 
1 - 9 of 9 Posts
Top