TCCoA Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
66 Posts
Discussion Starter #1
guys im confused wich controls the signal to the idle air control valve ive changed the constant control relay module inside the engine comp.do i need to change that box on the passenger side by the glove box...? because when i start my car it still searches for the right rpm setting im used to it starting right up and idling perfect not fluctuating..any help would be appreciated...
 

·
Newbie
Joined
·
5,650 Posts
That CCRM you changed was a bunch of relays. It has nothing to do with controlling the IAC. That "box" by the glove box is the car's computer (PCM) which controls nearly everything.

For a fluctuating idle, look for a vacuum leak. If the PCM was hosed, you'd likely have much more problems than a hunting idle. If you must replace something do the IAC before the PCM.
 

·
Registered
Joined
·
66 Posts
Discussion Starter #3
i did change the iac i dont know whats up i changed the iac and the engine still woulnt stay on so i changed the ccrm wich i thought was the pcm and it worked ...it just searches for the right idle setting now ...should i replace the pcm ....i mean this just happened one morning the car was fine the day before i started the car and it kept turning off ,what else could it be???thanx for the help....
 

·
Registered
Joined
·
892 Posts
Have you pulled codes. Just because the cel is not on does not mean the computer doesnt have codes. You own one of these cars the 1st tool purchase needs to be a code scanner. You have OBD II so you have a wide variety of scanners to chose from. You can even go to Walmarts and buy a good one. Just a thought. Replacing parts will cost you a fortune. If your anywhere near as good as I was when I started it will always be the last part that fixes it. I need to go check those credit cards and see if I finished paying for all of it. :rofl:

Brad
 

·
Registered
Joined
·
66 Posts
Discussion Starter #7
ya sounds good i cleaned the maf sensor and it didnt help ,went a head and changed my spark plugs again i put in erideum ngk plugs last week didnt really like em so i put in good ol motorcraft much better ...well thanx for the help ,,,,hope i find the problem....
 
1 - 7 of 7 Posts
Top