TCCoA Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1,119 Posts
Discussion Starter #1
Today my temp gauge hit an all time high of almost 3/4 on the needle. I had the AC on full blast as well. The temp stays at about 1/4 for the first 20 minutes of driving and will start going up as I put a heavy load on it or as above, it's hot out (alsmost 100) and the AC is cranking and putting the throttle down - alot (rush hour - everyones in MY way!)

I am not sure if it's the pump or the radiator.

New heads
Little loss of fluid
New hoses
New T-stat - 192
New belt
Fan comes on when the temp is at 1/2 - everytime and when the AC is on, the fan is on full time. So the fan is working, t-stat is good, correct mixture of fluid.

What else could it be? My bet is to replace the water pump @ $50 and then the rad at $$$ if it needs it. Rad is about 10 years old and the engine has 120k.

Thanks!
 

·
Registered
Joined
·
4,407 Posts
Why don't you do a pressure check???I just recently found a very slow leak in my system that has been there since I did the PI swap.(2 years now).It only leaked when under pressure.
 

·
Registered
Joined
·
647 Posts
Might look into what was happening with my car.

Mine was doing the same, the gauge was dancing and would climb whenever my subwoofer hit and would "overheat", and I replaced the brass sensor that actually goes to the gauge (it was like $5.00) and I havent had a problem since with it climbing ever since.
 

·
Registered
Joined
·
1,119 Posts
Discussion Starter #5
Thanks guys. My neighbor has a pressure testing unit and I will do that first. After that, a better gauge!
 
1 - 5 of 5 Posts
Top