TCCoA Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter #1
I have had this very annoying "creaking" noise when I turn my wheel - but intermittently.
It is worse turning to the right but will happen going left as well.
It will make this noise if I just rock the steering wheel just 1" back and forth.
If I kneel on the left bumper and push up and down I can hear the creaking noise.
It is intermittent.

Here are a few things I have tried

1. Changed the PS fluid and did a flush - it is VERY clean now. It was black, and I did get some black flakes of something in the fluid? It does steer easier now. Even though it is still kind of hard sometimes.

2. Lubed EVERY rubber bushing on the left front side - where the noise appears to come from.

3.Greased the left tie rod - this appeared to stop it for a short while - it came back.

4. Replaced the tie rod - this again took care of the noise for about a week - now it is back.

Oddly enough - this creaking seems to go away for a period of days - if I just jack up the car. Strange??

I have run out of ideas - anyone have any suggestions????

Thanks
 

·
Registered
Joined
·
793 Posts
Upper and lower ball joints, both sides to be safe. Been there, done that! Same sound, same attempts to rectify it.
Sideoiler
 

·
Registered
Joined
·
29 Posts
Discussion Starter #4
Hey Guys
Boots are not cracked - I jacked up the front end and tried to see if I had any play in the ball joints --- none. Very tight.
Any other ideas?

thanks
Leggo
 

·
Registered
Joined
·
1,610 Posts
tie rod ends... do a search there was a very good post about front end noise... in fact it may be a sticky
 

·
Registered
Joined
·
29 Posts
Discussion Starter #7
Whats funny is that I have a "creaking" and not a "clunking"..... already looked at the sticky. And I replaced the tie rod end. See number 4. of my post ;)
 

·
Registered
Joined
·
793 Posts
My boots weren't cracked, either. And they seemed tight to me. However, after replacing nearly everything else, the ball joints were the last thing I was thinking about. That is, until I got advice here about how you can be fooled about their actual condition. Replaced uppers and lowers on each side and the noise vanished. Mine, like yours, would not do it all the time, but I really noticed it after they dried out after a good rain. Inspecting them after removal revealed lots of dirt, metal particles etc, indicating they had been repeatedly force fed grease over a long period of time using a needle grease fitting; you could see the pin point holes if you looked closely. But, they sure looked good from the outside! Sideoiler
Leggo said:
Hey Guys
Boots are not cracked - I jacked up the front end and tried to see if I had any play in the ball joints --- none. Very tight.
Any other ideas?

thanks
Leggo
 

·
Registered
Joined
·
2,936 Posts
I have to second what Sideoiler said. Everything looked good, but I got new uppers and lowers from Rockauto and the creaking magically disappeared.


Russell
 

·
Registered
Joined
·
1,610 Posts
Seeeeee.. i tolda ya soooo. nah, im just kidding when the sticky says clunk i think it means any front suspension noise because there are some of those things that would DEF NOT make a clunk. My ball joints dont clunk, they pop AND creak.
 

·
Registered
Joined
·
29 Posts
Discussion Starter #11
OK OK - I will do the ball Joints:tongue: Will let you know how I make out. Thanks for your help ---- you to HanMan;)
 

·
Registered
Joined
·
287 Posts
balljoints, and prolly would be better to replace the upper controll arm, and wack the lower balljoaints out, and knock in the newones, not that difficult, just time consumping without the press
 

·
motor city poster
Joined
·
2,029 Posts
haha ball joints...

mine had good boots, no play, and they were worn out....tech brings it outta the shop, told me to go another month or so to see if noise gets worse, he keeps backing out, and bang...ball joint breaks and car drops to ground!! thats my story with ball joints :D
 

·
Registered
Joined
·
29 Posts
Discussion Starter #14
Hey - just to followup --- I changed the tie rod ---- nope. It was the ball joint. No more noise.
 
1 - 14 of 14 Posts
Top