TCCoA Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2,806 Posts
Discussion Starter #1
I am getting a creakfrom the front end in my steering going left and right at slow speeds. Also have a small knock when going over uneven pavement at slow speeds. I think the two may be related but I have run out of ideas to what they could be. The upper and lower control arms, strut rod bushings, and hubs within the last two years and I belive the outer tierods were replaced at the same time. I have recently done brakes and replaced the front swaybar links, thought these were the problem, with no improvement. When I added the front shock towere brace it made things worse. The only things I can think of it being now is the steering rack, rack bushings, or inner tierods. Anyone else have any ideas as to what it could be, the Ford service CD wasn't much help.

Thanks,
-Bryan Miller

Edit: Car has about 140k on it right now.
 

·
TSTaCC President
Joined
·
885 Posts
Mine is doing the same thingf and last time I had the car aligned the Ford dealership told me I needed a new "steering shaft busing."
 

·
Registered
Joined
·
680 Posts
I am at 140k myself and I am having the same problem. I am going to do strut rod bushings (I did both uca and lca) and also going to do tie rod ends. If anything changes for me, I'll post it up here and hopefully you do the same
 

·
Registered
Joined
·
5,978 Posts
bryan it sounds like what i have going on, mines inside the rack, and you turn clunk , pull into a driveway, clunk
 
1 - 5 of 5 Posts
Top