TCCoA Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Went out to start the Cougar the other day. It was cold, and the battery was low, and it didn't start. I hoooked up the charger, and came back an hour later. The function lights come on when I turn the key to "on", but when I turn it to start, nothing happens. Then, the park lights start flashing along with the park brake light on the dash. Can anyone tell me what's probably wrong with the car. I just need some kind of starting point. I've had this car a few years, and am just not real familiar with the systems on it.

Thanks for any help in advance.

Coop
 

·
Registered
Joined
·
1,746 Posts
1) Does your lights dim when you turn the key to crank it?
2) How cold did it get? Did you try tapping the starter to make sure the solenoid didn't lock up?

Etc Etc Man
 

·
Registered
Joined
·
251 Posts
Take your battery into any parts store they can usually test your battery or other components for free, that way you can pinpoint the problem immediately instead of buying parts on a hunch. mine did the same last winter, i had the battery tested and sure enough it was bad even though it was working strong just hours before.....
 

·
Registered
Joined
·
6 Posts
Discussion Starter #4
Checked the battery first thing. It was not good, so I replaced it. Same problem. That's why I decided to ask here. Is there a computer that controls the starting system on this car? Why would the park lights flash? Seems like there must be something electronic messed up.

I don't think the starter is frozen up. It turned over fine, but the battery was just low on juice, and it warmed up quite a bit before I tried to start it again.

Thanks
Coop
 

·
3rd Gear Chirper
Joined
·
2,399 Posts
The dash lights flash because the battery being low was screwing with the anti-theft module (if you have it) and/or the remote keyless entry module (you gotta have this one if your parking lights are flashing).

Low voltage can sometimes damage electronic components. If it's cranking but not starting, and the parking lights are flashing, the old battery might have messed up the anti-theft module which is the only module that can disable starting on these cars. If you don't have factory anti-theft, then you have another problem.

EDIT: you don't happen to have an aftermarket alarm or remote starter, do you?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
What next?

OK, I have replaced the battery, replaced the keyless entry/ anti-theft module, and checked all the fuses. No change. I hooked up a remote starter switch, and the car starts and runs fine. The signal lights still flash. I would suspect the ignition switch, except for the signal lights flashing. Any more ideas?

Thanks again,
Coop
 
1 - 6 of 6 Posts
Top