TCCoA Forums banner

1 - 20 of 24 Posts

·
Registered
Joined
·
1,136 Posts
Discussion Starter #1
Well I finally made it to the track and I didn't like my times. 15.7 was my best. My car is really in need of an intake. I could use a gear to but I couldn't hook. I tried everything. I just don't know if those times are right for the mods that I have. However they may be cause it seemed that the car was slow or late going into the next gear. This may just be do to the intake but I am not sure. What do you think? I will post the other information on the printout in the morning cause I left them in my car.
 

·
Registered
Joined
·
1,136 Posts
Discussion Starter #3
Well your car seems to be benching lots of wieght:D

Does that mean that you think those times are ok
 

·
Registered
Joined
·
654 Posts
I reccomend a marauder torque convertor - Dennis had them for around $100.00

Also Trac-Loc w/ 3.73 gears - Depending on Temperature and Humidity
my times are between 14.79 = 15.20's


CurtisA
 

·
Registered
Joined
·
7,758 Posts
Also, what tires are you running?

Both my 94 T'Bird (3.08 non-posi) and my 97 LSC (3.27 posi) could not get any traction!! :mad:

But they both have very, very hard tires (treadwear = 460 on the T'Bird, and 560 on the LSC) :eek:
 

·
Refrigerator Raider Hater
Joined
·
11,719 Posts
The weather can be a big factor, but my 96 ran 15.7 when 100% stock, I didn't even remove the spare.

We would need to see the entire slip to tell if it's the weather, the car, or you.
 

·
Registered
Joined
·
3,391 Posts
I just did a 03 Exploder swap and I am running 16.7, why you ask?? No tune, no posi, no jmod, no TC, etc, I olny have a custom dual exhaust and thats about it.
I was kinda mad/sad of the numbers, but I know it can get way better one's I do all of the stuff mentioned above.


Slips over here kinda suck and only give you so few stuff;

Elapsed Time 16.75
Vehicle Speed 81.27
Reaction Time .864
Total Time 17.614


I am really NOT happy with these numbers, but since my pockets are empty due to the swap, it might take me a while to put a TC, jmod, posi/4.10, cooler, MAF, etc, but I can live with that.
 

·
Registered
Joined
·
4,205 Posts
I'd say something else is wrong then. I ran 16.10 @ 88 mph, with a factory '95 engine, with K&N, custom exhaust, and pullies. Even without a tune, you should be much faster than 16.7.

And midnight, depending on weather, I'd say your times are pretty much right for your mods.
 

·
Jedi Master
Joined
·
3,647 Posts
not to mention our higher elevation, where as if we were in houston, with a lower elelvation, our times would drop about half to 3/4 of a second
 

·
Jedi Master
Joined
·
3,647 Posts
don't know but i'll find out, the reason i post that is because i have many friends that keep telling me that when they went to Dallas they went from running low to mid 10s to high 9s plus they would pick up the front end evenly and not just one side
these are hard core racers (mustang racers of course)
 

·
Registered
Joined
·
1,136 Posts
Discussion Starter #15 (Edited)
Here is a couple of them

R/T .724 .691
60' 2.194 2.253
330 6.513 6.571
1/8 10.040 10.114
mph 70.47 68.93
1000 13.149 13.220
1/4 15.776 15.851
mph 84.06 87.35
 

·
Registered
Joined
·
4,205 Posts
Hmmm, your 60ft. times look good, but your mph is really low for your times. I ran 16.14 @ 87 mph this weekend, on a 2.4 60ft. time.
 

·
Registered
Joined
·
1,136 Posts
Discussion Starter #17
Tire size is the 265/50sr15 BFGoodrich radial ta
 

·
Registered
Joined
·
635 Posts
yeh in lubbock, were at 3300 feet. I just got back from houston and oooo how i miss the elevation factor. My car ran sooo much harder down there. But up here in lubbock, i run a 16.1 at 85 with 2.36-2.41 60'
 

·
Registered
Joined
·
3,391 Posts
mn12xr7 said:
our elevation is 3,710 above sea level


Damn, I knew we were hi, but not that high.. Dammit, I hate El Paso:mad:
 
1 - 20 of 24 Posts
Top