TCCoA Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
615 Posts
Discussion Starter #1
I think the EEC on my 97 sport just pooped on me, put it on the scanner yesterday and it was giving the MAF no voltage and the barometric reading was way off, we just cleaned the MAF, we'll should be getting a used EEC on wednesday or have a local guy check the EEC out, if the EEC is fine then its gotta be somewhere in the wires running to the MAF, it seems like the computer is on a lock mode, cause every time you start the car even after reseting the computer same numbers keep coming up. If you guys think it could be anything else, let me know.
 

·
Registered
Joined
·
615 Posts
Discussion Starter #3
you could be right, but i have a new EEC comin from Ford on thursday if it doesn't work then ill try the MAF, i think my dad tried an other maf, I'll have to check up with him and see what he is doin.
 

·
Registered
Joined
·
1,160 Posts
Sounds like you very well couldve not been careful enough while cleaning the wires.
 

·
Registered
Joined
·
615 Posts
Discussion Starter #5
well put a new EEC in it and it was still doin the same thing, after doing some research here we added a new MAF to it and now things are A okay. As a dealer my dad got a good deal on the EEC so its not like we spent a big chunk for nothing. It was $275 for a factory refurbished atleast I know it is good. Thanks for the help guys.
 

·
Moderator
Joined
·
8,239 Posts
sounds like you spent a big chunk you didn't need too. for 275, you could have gotten a performance tune.

You could have gotten a junkyard eec for 40 bucks pretty much anywhere, they are a dime a dozen.

As for the maf no voltage code, verify that the maf is indeed plugged in fully, and the wires are not burned out/shorted.

JH
 

·
Astrophysicist / PostWhore
Joined
·
2,028 Posts
Well, I guess I'm glad to see you got your EEC issue resolved. Sorry to say, I only paid $25 for an EEC from a '96 Mercury Cougar, and $xxx (not going to say) for a reflash...
 

·
Registered
Joined
·
615 Posts
Discussion Starter #9
the junkyard was charging $150 for a EEC and for less then $100 more i got one from Ford which was basically guranteed to work. yea i probably did pay a lot for the EEC but a performance tune would have been useless if my car is bariely even running.
 

·
Registered
Joined
·
1,598 Posts
Well, now you own your first diagnostic tool, a spare ECU.... I buoght mine at a junk yard as a spare to use as a test box to eliminate that possibility first.... too bad you paid retail, and too bad that the boxes never failed in almost 300k on my two 95 LX's LOL
 

·
Registered
Joined
·
615 Posts
Discussion Starter #11
I wish I could say i have a spare computer layin around, but Ford was charging $100 core for the EEC and $75 Core for the MAF so no spares for me. the computer to my feeling probably was fine, but I guess if my dad would have just listned to me in the beginning about the MAF he probably could have saved $75, but if its anything about cars, i have to break my arm and leg just so I can prove my dad that I was right. When it comes to PC's then I own him LOL.
 

·
Registered
Joined
·
1,598 Posts
Oh, well.... My spare ECU was never needed , but mighty handy, and as for pc's I'm 63 years old, running a 2001 Compaq Presario 5000 series that I have modded a bit, useing a W.D 120 gig Caviar as a master and a W.D. Caviar 80 gig slave with XP and ME opsys', Ati 8500 128mb graphics, 1 gig RAM, Blaster V.92 modem, Xtra cooling, Round cables instead of ribbons, 6 xtra usb2.0 ports, and a few other "toots and whistles".. The 1.3 gigahertz T-Bird chip is fast enuff, due southbridge and front side buss speed, so I don't think any of my kids or grandkids will "own me" re; pc's for a while....
......................................................................................................................................
'95LX, 5.4 L, 177,000on chassis, and a blower on its way to make things more interesting for an old man LOL
 

·
Registered
Joined
·
615 Posts
Discussion Starter #13
haha, one in a million. My 1.33 T-bird is getting to slow for me, now i got my new bird, and all my new computer plans went to hell.
 
1 - 14 of 14 Posts
Top