TCCoA Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
43 Posts
Discussion Starter #1
:( K i toke off my EGR
Ok i have a trouble code called 31 which is a vacum leak but the problem is is that if i floor the pedal to the floor it stutters or chokes i guess is how u could put it i cleaned it out i got the value moving with needle nose but when i put it on the car it seems like it don't work i checked all the hoses replaced the one that were broke and stuff. Is it the cadliac converts because when u floor it it sounds like there is something blocking the exaust. If an ideas Please email me at [email protected] or just replay thanks for your help. :(
:2huh:
 

·
Registered
Joined
·
3,902 Posts
possible

I'm a bit confused by your post but yeah if your catalytic convertors are clogged, the car will have def decrease in power and there will be a noticeable hissing sound of the exhaust escaping from the car. Get someone to stand behind the tailpipe and feel for exhaust coming out, if there isnt much at all, I would definitely suspect clogged cats. As for the egr moving, the best way to check it is with a vacuum pump. If the pin inside the egr moves when given vacuum, then the valve is more than likely ok and the EGR problem probably lies somewhere else in the emissions system. Hope this helps
-Rob
 

·
Registered
Joined
·
43 Posts
Discussion Starter #3
Thanks i did take one of my cats off the probrlem is still there but i don't know where to get the vacum pump at.
 

·
Registered
Joined
·
3,902 Posts
vacuum pump

A vacuum pump is a tool that you can buy or borrow from someone. Rather than buying a vacuum pump you could find a vacuum hose on the engine that u can put on the egr valve while the engine is running. If when the EGR valve is opened (by the vacuum from the hose) the engine idle speed will drop and the car may idle rough. This tells you that the EGR valve works just fine. If nothing happens, double check that you really are giving it vacuum. If you are, then the egr valve is stuck (could possibly be cleaned with b-12 or replaced). If you happen to get a vacuum pump, just hook it onto the vacuum nipple on the egr and pump it up while the car is running, then look for the idle drop described above. If you are in central texas area I can help you look at it sometime if you have any more questions.
-Rob
 

·
Registered
Joined
·
43 Posts
Discussion Starter #5 (Edited)
Hey does that egr valve hose that goes on top of it is it supposed to have vacum and does the sensor is that supposed to have vacum to thanks for all your help. :)
Or could it be the timing on my car becase when i graduly gain speed ot os fine half the time but when i try to floor it, it hesataites and seems like it is going into netrual.
 

·
Registered
Joined
·
3,902 Posts
vacuum!

The hose that goes on the EGR should only get vacuum when the EVR solenoid puts vacuum to it. The EVR solenoid is the black or black/grey thing on the passenger side of the firewall. It has two vacuum hoses going into it, and two wires(red and i think the other is brown, maybe black). The top of it has a round piece. You need to make sure that the EVR solenoid is getting vacuum to it(the hose on the evr that doesnt go to the egr....pull it off the evr and put your finger over it, it should suck all the time when the engine is running..if not then its not hooked into vacuum properly) from the manifold.
-Rob
 

·
Registered
Joined
·
43 Posts
Discussion Starter #7
ok well my step mom has a sable with a 3.8 in it so i toke the egr valve off of it and the sensor and my check engine light went off but when i plug my sensor in (not using my egr valve) it turns back on. But the problem is that it still does it. When i changed out egr and the sensor it still does what i don't want it to. It is doing like this my rpms are about 2 - 2.5 idleing speeds are like 40 mph without touching the gas. I toke of my driver cat but my left is being a b*tch. I live in ohio. I am just running out of ideas i am just about to say screw it and sell it or take it to a dealer and pay 100 for the inspection. So far this is what i have done changed spark plugs and the pcv valve. Well if you have anymore ideas that would help out that would be great. Thanks So Much.
 

·
Registered
Joined
·
3,902 Posts
ideas

To test your EVR solenoid (black thing) hook it all up. Crank the car. Run a wire from the black or brown wire that plugs into the EVR to the negative on the battery. As soon as it touches the battery, the EVR should open(this means it gives vacuum to the EGR) then you should notice a rougher, slower idle(if the idle slows down when you grab this wire, the EVR works fine). As far as the crazy idle goes...you could clean your IAC valve. It sounds more to me like someone has been tampering with the throttle adjust screw on the throttle body though. Look on your throttle body and you will see a little arm that has two cables hooked up to it. On your throttle body there is a screw that meets this arm. Loosen the screw while the car is running and see if that makes a difference, if not, put it back where it was :) Sorry about this man, its just kinda hard to diagnose a car when you cant see it! Hope this helps!
-Rob
 
1 - 9 of 9 Posts
Top