TCCoA Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
279 Posts
Discussion Starter #1
What up the these eibachs, I bought the springs from my friend, He had them on his tbird, I put the on two weeks later and the front sits almost a stock height on the rear is fine. I put new uca's and swaybar endlinks on the front, Why would the car sit so high in the front? The aligment is not the bad is the front too. Would the new uca's and endlinks make it sit higher?
 

·
Registered
Joined
·
9,966 Posts
What up the these eibachs, I bought the springs from my friend, He had them on his tbird, I put the on two weeks later and the front sits almost a stock height on the rear is fine. I put new uca's and swaybar endlinks on the front, Why would the car sit so high in the front? The aligment is not the bad is the front too. Would the new uca's and endlinks make it sit higher?
mine were just fine. Pull the shock/spring assy and make sure everything is seated properly.
 

·
Registered
Joined
·
279 Posts
Discussion Starter #3
the thing is that his car sat fine, with them on, and 2 weeks later its all messed up on mine.
 

·
Registered
Joined
·
9,966 Posts
the thing is that his car sat fine, with them on, and 2 weeks later its all messed up on mine.

then pull the shock/spring assy. The eibachs didnt grow.
 

·
Registered
Joined
·
279 Posts
Discussion Starter #5
i understand that, what else could be cause this?
 

·
Registered
Joined
·
279 Posts
Discussion Starter #7
i never took the spings apart , the same shock and everything
 

·
Registered
Joined
·
279 Posts
Discussion Starter #9
ok sure will, i will let you know
 

·
Registered
Joined
·
279 Posts
Discussion Starter #10
everything looks fine, the rear isolator must be worn out on mine, I getting new ones
 
1 - 10 of 10 Posts
Top