TCCoA Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
driving home 2 days ago on fwy. engine started to stumble and lose power-then just died. could crank but no go. had towed to repair facility where it sat for 4hrs, they jumped in and it roared to life.
they ran diagnostics and came up with a code P019 (internal voltage unable to regulate). cleared code and were unable to recreate stumbling.
Upshot is they said maybe the ecu is failing, but were not willing to just throw parts at it (good).
anybody have something like this happen, if so what was the solution?
90tbirdSC
 

·
̇
Joined
·
3,701 Posts
driving home 2 days ago on fwy. engine started to stumble and lose power-then just died. could crank but no go.anybody have something like this happen, if so what was the solution?
I had something similar happen on a Taurus I had..

Solution=New Alternator



Rayo..
 

·
Registered
Joined
·
4,309 Posts
On the SC the Cam sensor can cause a no start also. DIS module itself is known to have issues also.

Highly unlikely the PCM goes bad .. its usually a signal feeding it.

Need to check for spark / fuel when it has a no start condition to verify.
 

·
Super Moderator
Joined
·
4,925 Posts

·
Registered
Joined
·
4,309 Posts
I second DAT module!


Wait ... what are we voting on now? *is confuzzled*

RwP
DIS for Distributrless Ignition System .. your 5.0 has a DI, so nothing you have to worry about. :tongue:

The problem with the DIS over the AC compressor is heat - they tend to act up more when they get hot, some people use heatsink compound like Artic Silver underneath the module to help prevent this issue. It was a huge failure item in the 90's.
 

·
Super Moderator
Joined
·
4,925 Posts
DIS for Distributrless Ignition System .. your 5.0 has a DI, so nothing you have to worry about. :tongue:
I know. I was making a joke about "I second DIS." "I second DAT!" :diablo:

'Salright, what I use in place of my missing sense of humor doesn't always work well.

RwP
 

·
Registered
Joined
·
4,309 Posts
I know. I was making a joke about "I second DIS." "I second DAT!" :diablo:

'Salright, what I use in place of my missing sense of humor doesn't always work well.

RwP
:D I got the joke .. ( smile and nods head .. :tongue: )

I have nothing to say.
 

·
Registered
Joined
·
183 Posts
When my car died on the high way my TPS failed. It would crank but rev and idle very rough. As soon as I would put it in gear it would hesitate and die. Replaced the TPS and it was resolved.
 
1 - 11 of 11 Posts
Top