TCCoA Forums banner

1 - 20 of 28 Posts

·
Banned
Joined
·
998 Posts
Discussion Starter #1
I have a problem, my 96 tbird 4.6 the engine misses under load after about half throttle....this has been a problem that I seem to be chasing...I replaced these parts so far.....new plugs wires (MSD), new plugs twice, a new coil on the drivers side the old one was broke at the connector, TPS, IAC. I have read a couple of threads on this but no one seems to have explained what fixed the problem......does anyone have some ideals???????????????

Thanks
 

·
Registered
Joined
·
5,978 Posts
try the other coil
 

·
Registered
Joined
·
522 Posts
As ashamed as I am to admit it.............. Changed I dont know how many wires and coil packs, but double check the wires and make sure 1 didnt get switched around. Yes, happened to me. :eek:
 

·
Registered
Joined
·
5,978 Posts
yea that is a good idea , i always triple check after i install wires
 

·
Banned
Joined
·
998 Posts
Discussion Starter #7
my car was running fine....it just started on its own...I then changed the coil after the miss came back....?????????????
 

·
MaleWhore
Joined
·
2,640 Posts
my car did the same thing...my aftermarket wires were actually arcing into the block...i put the stockers back on and it stopped...go figure...now i need new wires cause my old wires have 118k on them
 

·
Registered
Joined
·
522 Posts
smokymance said:
my car did the same thing...my aftermarket wires were actually arcing into the block...i put the stockers back on and it stopped...go figure...now i need new wires cause my old wires have 118k on them

aftermarket wires

But your sig says LIVEWIRES would that be the brand?
 

·
Registered
Joined
·
1,598 Posts
how old is your MAF?? anytime after 50k they can go, and start bucking without throwing a code...... If all else fails...
 

·
Premium Member
Joined
·
6,617 Posts
I have found an easy way to quickly check for a faulty maf. Tap on it(the plastic part while installed in the car) with the handle of a screwdriver. If the engine dies, the maf is dead.
If it passes that test clean it . I use an alcohol prep pad ,but you have to be careful not to leave any fibers on it.
Alan
 

·
MaleWhore
Joined
·
2,640 Posts
BirdofPrey97 said:



But your sig says LIVEWIRES would that be the brand?

yes unfortunately...i dont think i consider them aftermarket at all:D
 

·
Banned
Joined
·
998 Posts
Discussion Starter #15
If I was to replace my MAF, what year should I buy?...02 mutang????

And if I buy that one will it run ok or will it need to be re tuned...in order to trun ok??

I have a PI intake on it now and will be adding a bigger TB and upper in take soon also.
 

·
Banned
Joined
·
998 Posts
Discussion Starter #17
I got the other coil and cleaned my MAF..but the miss is still there the same way.....under load at half throttle..........DOES ANYONE KNOW OF A UPGRADE MAF AND CHIP COMBO...THAT IS NOT EXPENSIVE???????
 

·
Registered
Joined
·
1,598 Posts
Get an 02 GT MAF, and pig tail....Try dan Newman..... talk to Lonnie about a chip, and you should be all set. you could dig around for a better price,on any of that stuff, and maybe save a few bucks, (verry few) but this way youll be happy, and will have things that work ...... good luck
 

·
Premium Member
Joined
·
3,247 Posts
One way to see if it is the MAF that's bad, is to disconnect it, and take it on a short test drive. It should accelerate better, while it will idle poorly.

It MAY also turn the Check Engine Light on.

To reset the "light", just pull fuse #15 (hood compartment fuse box).

Then try to start the car (it won't), and then put the fuse back in.
 

·
Banned
Joined
·
998 Posts
Discussion Starter #20
How much bigger is the 02 maf...what size did my 96 4.6 have stock?.........what would be the HP gain from adding the 02 maf and the chip.....my mods are, no air silencer,no mufflers,PI intake, K&N,B&M shift kit,.......hummm?????
 
1 - 20 of 28 Posts
Top