TCCoA Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
92 tbird 5.0 completely stock
110,000 miles
AOD transmission rebuilt at around 80,000


Having an unusual problem with my bird. The engine is idling at considerably higher than normal rpm's (can't quantify since i don't have a tachometer) and when the car is in gear, it will slowly accelerate to 30 mph without any application of the throttle. The engine isn't running rough, just at high rpm's. Check engine light periodically flashes on. Upshifting seems fine, but the downshifting is hard due to the fact that the rpm's are high. Also, experiencing a rather loud "moaning" sound when the car is in nuetral or park. Any ideas, or possible causes would be greatly appreciated. Thanks in advance.

steve
 

·
Registered
Joined
·
538 Posts
Check Your

Check Your throttle and throttle cable under the Hood (you know the one that allows you to rev the enhgine by hand)....It's most likely stuck. If it is...then some WD40 will keep it from doing that again.

Beirutsfinest
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
I checked throttle and throttle cable and nothing appears to be stuck at all. in nuetral the throttle is flush against the "stopper." Any ideas. Thanks.
 

·
Registered
Joined
·
1,338 Posts
Your problem is the IAC valve. It is tge small piece held on with 2 small bolts to the throttle. It also has a electrical connextion on the rear. About $120 at Ford, and $70 any place else for same item.

Will take you about 15-30 mins to replace.
 
1 - 5 of 5 Posts
Top