TCCoA Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
Now that i have at least temporarily plugged most of the exhaust leaks, I can hear it leaking under the hood area while under load. (not really while at idle). and when I can hear it leak the CEL comes on. However if I drive Exactly 64 MPH, I cant hear the leak and the CEL goes off :) Can I install a flux Capacitor? Or maybe remove the hood strap someone to the top of the engine and drive around having them listen to see if its coming from the EGR setup :) lol
 

·
Registered
Joined
·
4,309 Posts
Now that i have at least temporarily plugged most of the exhaust leaks, I can hear it leaking under the hood area while under load. (not really while at idle). and when I can hear it leak the CEL comes on. However if I drive Exactly 64 MPH, I cant hear the leak and the CEL goes off :) Can I install a flux Capacitor? Or maybe remove the hood strap someone to the top of the engine and drive around having them listen to see if its coming from the EGR setup :) lol
CEL intermittent like that is usually an EGR related issue - it only comes on during load conditions at a certain cruising speed ( if your sound goes away during this I would suspect this may be somewhere near your issue source ) .. so many vacuum lines including the lines / solenoid that control the EGR itself. It would be best to smoke test the system - I have even found exhaust leaks at the gaskets between the head / manifolds.
 
1 - 2 of 2 Posts
Top