TCCoA Forums banner

1 - 3 of 3 Posts

·
Boom.
Joined
·
5,238 Posts
Discussion Starter #1
Well the bugs are almost all figured out...current issue at hand is the EGR Flow sensor. From my research on the differential pressure feedback EGR sensor (DPFE), this is in fact the EGR flow sensor that has been bugging me...on the Explorer it is 2F1Z-9J460-AA...but I don't seem to have one...

That said, I know that Tim used the Explorer piece for this, but can I use the Cougar DPFE sensor on the Explorer system? My Explorer EGR tube has the two hard lines coming off of it for the DPFE but no rubber hoses and no sensor in sight...

I also believe that I should be using the EGR Vacuum Regulator from the Cougar.
 

·
02 Explorer Pioneer
Joined
·
2,880 Posts
Yes you can use the cougar one. The reason I didn't use the tbird was just that I didn't want to bother with finding a place to mount it where the explorer one just sits on top of the tubes. You are correct use the cougar vacuum regulator. The end is in sight....are you getting excited?
 

·
Boom.
Joined
·
5,238 Posts
Discussion Starter #3
Oh yeah I am getting excited...I like driving the Explorer, I used to drive one before the Cougar but it just doesn't compare. I drove my dad's Bird today and the love resurfaced yet again! I was just imagining that my car will be even more powerful than the Bird and I've been thinking about January 30th today and trying to figure out the best launch technique...

I know, I'm pathetic....but it's been a long road that is almost over, this part of it at least!
 
1 - 3 of 3 Posts
Top