TCCoA Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
1,996 Posts
Discussion Starter #1 (Edited)

·
Registered
Joined
·
2,634 Posts
It looks like you can buy this with a FRAM oil filter and get a $5 rebate ($1.89 + $4.43 - $5 - Rockauto Coupon Discount + shipping = $1.32 - Discount + shipping)

-g
 

·
Registered
Joined
·
527 Posts
i changed to the airhog 2 weeks ago and when i floor it the car shifts at 4,000 rpm instead of 3,000 rpm like before. is this normal for changing to these or k&n etc.?
 

·
Premium Member
Joined
·
5,862 Posts
i changed to the airhog 2 weeks ago and when i floor it the car shifts at 4,000 rpm instead of 3,000 rpm like before. is this normal for changing to these or k&n etc.?
Your car shift point increased 1000 rpm just from changing your air filter? Do you have a pic of your original air filter?
 

·
Registered
Joined
·
527 Posts
Yes i know rite ..it dont seem rite lol. its just a regular cotton style panel filter. basicly brand new, was only on the car for about 4 months,still clean also
 

·
Registered
Joined
·
2,073 Posts
Theres something else going on. An air filter change will not make that kind of differance.
 

·
Registered
Joined
·
527 Posts
yea i was thinking maybe something else. before i did my trans/converter drain it was shifting at 2,5ish. after it was shifting at 3,000.which seemed rite to me. bt now its hitting about 4,000 coming out of 1st and also out of 2nd. the only thing i did was change filter and change this device i made. with the old air silencer amd the old flexible duct that comes on the 4.6 case.... i mean damn was it doing more constricting then benefiting.?

note- when just regular taking off it shifts out around 2300ish..this is normal correct? also no intake,engine,trans mods, just richardm tube
 

·
Registered
Joined
·
5,410 Posts
I have an Amsoil air filter on my Cougar 4.6

I won't put anything FRAM on my car.
I have K&N airfilters on all of my cars with no issues.
 

·
Super Moderator
Joined
·
4,898 Posts
I have K&N airfilters on all of my cars with no issues.
I put an Airhog on my 2000 Malibu - and the motor died within 2,000 miles! (Misordered the filter, wasn't aware it was a 'permanent' filter.)

OTOH, the Airhog had nothing to do with the surge tank blowing the top off ...

RwP
 

·
Registered
Joined
·
527 Posts
I put an Airhog on my 2000 Malibu - and the motor died within 2,000 miles! (Misordered the filter, wasn't aware it was a 'permanent' filter.)

OTOH, the Airhog had nothing to do with the surge tank blowing the top off ...

RwP
im confused so it killed your motor or didnt it?
 

·
Super Moderator
Joined
·
4,898 Posts
No, it didn't kill my motor.

Blowing the surge tank on a 104F day while travelling at 75MPH on a crowded interstate, THAT killed my motor. Or more accurately, the time I had to leave the motor running so I could pull over and off the Interstate killed it.

Can't complain too much - car had over 330Kmiles on it.

RwP
 

·
Registered
Joined
·
58 Posts
That's impressive!
Those cars were the biggest lemons ever.


Tank
 
1 - 14 of 14 Posts
Top