TCCoA Forums banner

1 - 12 of 12 Posts

·
CEO, WT Club
Joined
·
2,648 Posts
Discussion Starter #1
So I have some coolant running out of the car on the drivers side of the block, at right about the motor mount. There is no coolant in the oil. I can't see exatly where the coolant is coming from... but I think it may be a freeze plug? Are these metal, and has anyone ever had one crack and leak? It's either that or HG's. Any ideas? If it's a freeze plug, what does it take to replace one?

-Joel
 

·
Fry Rice Specialist
Joined
·
4,794 Posts
or it may just a block drain plug. it is right around that area too.

i forgot it is either metal or brass with wrench head on there.
 

·
Premium Member
Joined
·
9,165 Posts
Joel, have you got it down what is wrong yet?
 

·
02 Explorer Pioneer
Joined
·
2,880 Posts
To answer your question yes freeze plugs do sometime corode and leak.
 

·
CEO, WT Club
Joined
·
2,648 Posts
Discussion Starter #7
Well, I had a ton of coolant belching out the exhaust pipe last time I checked her out, so I am pretty sure she's blown HG's.

Micheal, do you know what's going on for saturday? I may have to go pick a car up in STL, but I should be back friday night.

-Joel
 

·
Premium Member
Joined
·
9,165 Posts
Don't know for sure whats going on Sat. I'd like to get a few runs in at MoKan, but that would be Sat. afternoon, giving me Sat evening to head for KC and all day Sun to work on your car if it fits in with your schedule. Just let me know if Sun works for you.
 

·
CEO, WT Club
Joined
·
2,648 Posts
Discussion Starter #9
Sunday is a no-no for work.

I can wait till next week/the week after (if I have to:() I am 99% sure I'm going to STL to get a car friday. Saturday bright and early I would be good, but I also have to stop at 4pm... to go to my engagement party.

-Joel
 

·
Premium Member
Joined
·
9,165 Posts
Drat. I won't be coming up to KC again till the Oct. meet (27th I think). I'd be happy to do it then if everyone else is.
 

·
Premium Member
Joined
·
9,165 Posts
:( I have :(

But, it may have been my own fault. I'm not sure the coolant was 100% in hindsight.
 
1 - 12 of 12 Posts
Top