TCCoA Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
424 Posts
Discussion Starter #1
At about 30 mph the steering wheel with rotate side to side. There also seems to be a slight vibration at highway speeds, I'm thinking related. 96 Cougar with ~60K on it. I replaced the upper / lower control arms, outer tie rod ends about a year ago. Recently (month or so) had tires balance rotated & alignment. I've been under there and seen nothing obviously loose / worn. There is a squeak from the passenger side top of spring / shock. Looking for some insight / direction on what to look for. Thanks.
 

·
Super Moderator
Joined
·
5,117 Posts
Before you worry too much, get some one to walk the steering wheel back and forth through the dead zone while you examine the intermediate shaft and rack.

Might be as simple as the rack bushings are failing. Or the inner tie rods.

That squeak from the top of the spring and shock may be a failing upper shock mount; how old are the shocks on it? Did you replace the shock (upper) and spring (lower) mounts while replacing the shocks? Or if you don't know, how about planning on replacing shock/upper mount/lower mount this spring or summer? (Do the rear shocks at the same time!)

Don't forget the sway bar end links; your car is old enough, they may be shot too. And if you do those, consider the sway bar bushings (I went for greaseable poly mounts on Ruby.)

RwP
 

·
Premium Member
Joined
·
372 Posts
Those symptoms could also point to a bad tire. You said they were balanced, if a belt slips or breaks it can still balance fine all while still giving you an out of balance feeling. I have had a tire go bad once and it made my car pull to a side.
Years ago I bought a set of cheap snow tires for my car at the time. I turned around and went back after I picked up the car, I thought they forgot to balance them... Turned out 3 out of 4 new tires had bad belts. That was the last time I bought Chinese rubber.
 

·
Registered
Joined
·
424 Posts
Discussion Starter #4
Thought of the intermediate shaft. Did not think of the rack bushings nor the tire belt. Will check those out.
Sway bar end links are ~1 year old also. The shock mount was not replaced with the the rest, adding those to the to do list. I had inner tie rods wear out on my previous Cougar and on my Explorer, this feels different. The steering still feels tight.
 

·
Registered
Joined
·
424 Posts
Discussion Starter #5
It looks like the rack bushings. Rockauto has a set of Moog for ~$12. Out of curiosity I looked at SCP and they want $50 for a set of poly bushings. I know SCP can be overpriced, but is there really much of a benefit to the poly ones? Any other suggestions for these? Thanks.
 

·
Super Moderator
Joined
·
5,117 Posts
Well, it depends on how spirited you drive.

I did poly on Ruby Jean just because; but there's no big reason TO.

OTOH, I used Energy Suspension poly bushings; they're a bit less than $50. Currently they look to be about $13.06 (as of this posting).

Let Google do the walking; the right part numbers are somewhere in the forum here (albeit they're Mustang bushings).

You do NOT want the offset bushings; there's two sizes, and to fit the old center bushings (which you recycle), you have to get the right size.

RwP
 
1 - 6 of 6 Posts
Top