TCCoA Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
134 Posts
Discussion Starter #1
The check gauges light comes on for low fuel.....yet it only take 12 gallons to fill it. I replaced the fuel pump/sender assembly.....same issue.

Pulled the dash, everything was plugged in.

Seems like its about a 1/4 of a tank off.....200 miles of highway driving and then the tank shows empty.

Any ideas? How do you check the gauge itself?
 

·
Registered
Joined
·
276 Posts
Yea if you only added 12 gallons you should of had 6 still in the tank for a total of 18. Was it doing this before the new fuel pump/sender. It sounds like it was but just making sure. Which one of your birds is having the problem. Have you tried swapping gauges yet.
 

·
Registered
Joined
·
134 Posts
Discussion Starter #3
The reason I swapped the pump was to fix the problem. Its the 95 sc that's doing it.
 

·
Registered
Joined
·
128 Posts
I have this same issue, it didn't happen until after I replaced the fuel pump for a bigger one.

I've always chalked it up to a bent floater, reaplacing the gauge did not help.
 

·
Registered
Joined
·
134 Posts
Discussion Starter #5
That's what I thought, hence why I replaced the pump and sending unit......its annoying that's all.
 

·
Banned
Joined
·
613 Posts
I have the same exact problem!!

It actually started happening the same day after i put in a new tranny. For some reason my fuel gauge, coolant temp. gauge and dash temp. reader are all out of whack a but bit... very weird. Still haven't really researched it to find out more
 
1 - 6 of 6 Posts
Top