TCCoA Forums banner

1 - 16 of 16 Posts

·
Registered
Joined
·
48 Posts
Discussion Starter #1
hey all.I plan on doing the PI Intake swap wothin the next month or 2 and was wondering if anyone knows of good supplier of aftermarket or OEM 19# injectors for my bird(97 4.6).I've managed to find these( http://www.fiveomotorsport.com/Injector_SetsFORD.asp#foted5b) but they only say up to 96 t-bird,but they also say 96-02 mustang.So my second question is if any 19# injectors that will work for a 97 mustang non-cobra will work for my bird.

thanx for the responses in advance.
 

·
Registered
Joined
·
48 Posts
Discussion Starter #3
figured i'd replace them while i'm in there and have the motivation to do it.Plus every once in a while,especially in the tunnels under boston where the sounds is more noticable,i'll hear a funky noise from the engine that kinda sounds like a diesel or knocking sound(dunno which would better describe it) in the first 2 seconds or so when i accelerate after braking or such.a friend of mine from a previous job used to be a dealership mechanic for ford said that the sound is most likely caused by the injectors.
 

·
Registered
Joined
·
1,598 Posts
I doubt the 'jectors are going, as they uasually seem to last about forever... I have a set with about 100K on em, you can have for 30 bucks, if interested, but I bet you that isnt the prob...I am now running 42# with a blower... waay too much for 5# of boost, but they will last longer than I will...good luck
 

·
Registered
Joined
·
48 Posts
Discussion Starter #5
yeah,i've got about 125k miles on the stock ones right now and i think i'm the only one who owned the car in the family who tried using fuel injector cleaner so i dunno. have any ideas on what else my be causing that noise(hope the description i gave earlier was enough)?
 

·
Registered
Joined
·
1,598 Posts
You sure it isnt some spark knock? thats pretty common, and easy enuff to Identify, just go up one grade on fuel, and see if it goes away..... ( a lot cheaper than new injectors) My car was running crappy , and had a lotta spark knock a few years ago...tried everything, but in the end it was early breakdown of the MAF, go figure...
 

·
Registered
Joined
·
48 Posts
Discussion Starter #7
i've been using 89 for a while now....93 is still over $2 a gallon here.i tried that when i first started noticing it cause someone suggested that here and it didn't really help it.i'll try to clean the MAF again and see if thats causing it,keep forgeting how much trouble that damn thing can cause.thanx for the help.
 

·
Registered
Joined
·
178 Posts
Charley didn't affect us around in the area's we live in. South of Clearwater was the worst.

That sounds like timing knock to me. Like in my 5.0 i can adv. the timing and get ping under hard accl. on 87, but run 93 on 14deg base and it lights the tires from 2-1 downshift w/o ping. Also one more thing... You might need plug wires. My Cougar did it a little w/ the old wires then I got the FMS 9mm and it went away. I could open the hood at night and start the car then rev it while at the engine bay an watch spark jump from wire-wire. Try it and see
 

·
Registered
Joined
·
48 Posts
Discussion Starter #10
hmmm,i'll check it out.its been about 2 years since i replaced the plugs and wires.If it does turn out to be that does anyone know what the part # for new fuel injector o-rings are so i can replace them at least(can't afford to lose my car for a week cause i ripped an o-ring).Also,is there a preffered method to clean the injectors while they're out of the engine?
 

·
Registered
Joined
·
48 Posts
Discussion Starter #11
no one knows the part number for the o-rings?
also, someone listed the p/n for the updated thermostat housing bolts to be N811011-S309,but i tried looking it up on fordparts.com and it's not finding it.any ideas on this one?
 
1 - 16 of 16 Posts
Top