TCCoA Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
694 Posts
Discussion Starter #1
Started my car yesterday to discover it idling rough and smelled fuel pretty bad. I had fuel leaking underneath my car near the transmission (passenger side). I figure maybe a fuel line broke? Doesn't seem to leak when its shut off though. Just thought I would throw it out there and see what you all thought. Thanks.
 

·
Registered
Joined
·
674 Posts
could be the connection at the fuel filter leaking... they're the quick connect type. (at least one side anyway) and can get brittle and leak. Most auto parts stores have repair kits w/ seals etc... the fuel filter is located about mid door on the pass side along the frame rail.

Hope this helps.

PS. Leaking fuel will cause fuel pressure to drop, thus causing the car to run lean, giving you the rough idle you mentioned. Try not to run the car too much like this, as lean mixtures tend to do far more damage than rich mixtures. Plus you dont wanna be dumping that 4 dollar per gallon fuel all over the ground, right? lol... I have a leak at my tank, i know how much it sucks...
 

·
Registered
Joined
·
694 Posts
Discussion Starter #3
Yes it does. I gotta take it to a shop to have the brakes fixed this next week... so ill just have them look at that as well. Thanks.
 

·
Registered
Joined
·
694 Posts
Discussion Starter #5
Well, I took the car into the mechanic today. Man she was running rough. When I got there I got out to notice a lot smoke coming outta the tailpipes. Is this to be expected with a lean condition, when leaking fuel? Or do I have something more engine related then just a leak? Im sure I'll find out soon enough from the mechanic... just asking your alls opinion for the hell of it.

Honestly, I hope the damn engine is wasted so I have reason to drop in a PI motor haha. *crosses fingers* Thanks.
 

·
Registered
Joined
·
674 Posts
if its black smoke, then that usually indicates rich... odd... oh well, have u found anything out from the garage yet?
 

·
Registered
Joined
·
40 Posts
it might be your ecu going out ,hanging a injector open causing all the white smoke coming out your tail pipe ,if it smells like gas ,just to throw that out there for you
 

·
Registered
Joined
·
694 Posts
Discussion Starter #8 (Edited)
Yep, called up the mechanic today. First thing he asked was if I had a performance chip in it. I said yea, and he was like "thats your problem, its causing the ECU to hang an injector open and gas is pouring out the exhaust." I am very skeptical that its the SCT chip i have in it. It has worked fine for 4 years now. Is my ECU just dead? Now I guess I have to look into getting a new ECU with the same catch code or reburn my chip for a different ECU code eh?

EDIT: Do chips cause ECUs to fail? Or was it just coincidence? It was one I had burnt by Lonnie.
 

·
Banned
Joined
·
613 Posts
I had the same problem yesterday morning. upon further investigation I discovered its leaking from the line somewhere. passenger side under rear window.

I narrowed it down to about a 1.5 ft area. There are some kind of bolts that hold all 3 lines together. But you cant remove them because they are round. any one have ideas o how to fix this either temporarily or permanent?

It only leaks when car is on. Than when it shuts off, it leaks for another minute. Than stops.
 

·
Registered
Joined
·
704 Posts
EDIT: Do chips cause ECUs to fail?.
only IF it was removed from the PCM while the key was on.
OR wiggled itself loose while the key was on.

I'd pull the chip and see if the problem still exists, doubtful/impossible that the chip actually "caused" the problem, but either of the scenario's above could have smoked the PCM or the chip or both..
 
1 - 10 of 10 Posts
Top