TCCoA Forums banner

1 - 15 of 15 Posts

·
Registered
Joined
·
515 Posts
Discussion Starter #1
ok, my bird was having some probs about a week ago, when i was talking off it was really doggy like it wasn't running on all 8 cylinders.
then once you were going about 25 or so faster and would floor it, the rpm gague would just go up and the car wasn't moving any faster.

i replaced the plugs and wires now its running on all 8 but still when i floor it i just get lots of RPMs but its not moving any faster or accelerating.

its getting looked at now one guy thinks i might be MAF sensor.
do you guys have any opinions?

thanks
 

·
Registered
Joined
·
515 Posts
Discussion Starter #3
so a MAF sensor sounds about right?
also i do plan to mod this car is there something other then stock i should replace it if its the problem?
 

·
Registered
Joined
·
9,966 Posts
TC is slipping, check your ATF fluid, you might need more...or your transmission is fubar. Which is both god and bad - you can pick up a newer mustang GT trans for a few hundred and make some minor modifications to make it work.
 

·
Registered
Joined
·
2,662 Posts
What about the MLPS? Wouldn't that cause this as well as a fubar'd TC?

Jay
 

·
Registered
Joined
·
515 Posts
Discussion Starter #8
TC is slipping? whats TC?
ATF? whats that?
whats the bennifits of the new mustang GT trans? would you still jmod that?
whats a MLPS?

ok now after all them questions lol
just went up there and talked to the machinic and we took the MAF sensor off got some MAFS cleaner spray, sprayed it in there and then took the car for a ride and it went great. so hes going to keep it over night take it in the AM when its cold and see how she goes and hopfully that fixes the problem.

oh and i looked in the records in the 7 years ive had that car this would be the 4th MAF sensor that was put in, any ideas why it would go bad?
 

·
Baby Huey
Joined
·
3,210 Posts
TC= Torque Convertor
ATF=Automatic tranny fluid
MLPS=Manual lever position sensor
GT tranny is stronger and yes you will still benefit from a jmod
 

·
Registered
Joined
·
2,662 Posts
Is that the stock transmission? How many miles on it? Are you running Mercon V in it, or Mercon/Dexron III?

Jay
 

·
Registered
Joined
·
1,324 Posts
If she comes back to life after the MAF cleaning (meaning the tranny acts normally), I highly recommend changing to Mercon V and doing the j-mod and adding a transmission cooler. If you can't do the work, your mechanic should be able to walk himself thru the tech articles on it. I had never been inside a tranny before and was able to pull it off using them. CAUTION: make sure to mark each and every hole to drill and triple check them and the drill bit before actually drilling. You'll know what I mean when you read the articles.
Rob
 

·
Beer and Cheese
Joined
·
7,386 Posts
Fordraceing said:
i replaced the plugs and wires now its running on all 8 but still when i floor it i just get lots of RPMs but its not moving any faster or accelerating.
Sounds like a trany problem to me, lots of RPM's and not moving any faster or accelerating? The TC isn’t locking up or slipping. Ask dirtydog on your symptoms cause it sounds like a trany problem
 
1 - 15 of 15 Posts
Top