TCCoA Forums banner

1 - 6 of 6 Posts

·
Cougar Pilot
Joined
·
3,443 Posts
Discussion Starter #1
Apparently the tie-rods are screwed all the way in?

I installed them myself from RockAuto (Moog) and they figured that I used the wrong parts, I would be surprised though. I asked what the solution to this was, I was told that they can always pull them off and cut them down.

I'm thinking there's a setting they missed or something else. I was told it's aligned for now but there's no more adjustment for the future.

Any ideas?
 

·
Registered
Joined
·
42 Posts
I don't see how that would be possible unless it was the wrong parts but i'm no alignment guy so I could be wrong.
 

·
Super Moderator
Joined
·
5,168 Posts
Some rebuilt racks have come with Mustang inner tie rods, that are longer than the MN12 ones, yielding this exact same situation.

Wouldn't surprise me if that was the situation.

RwP
 

·
Registered
Joined
·
613 Posts
I asked what the solution to this was, I was told that they can always pull them off and cut them down.
Some rebuilt racks have come with Mustang inner tie rods, that are longer than the MN12 ones, yielding this exact same situation.

Wouldn't surprise me if that was the situation.

RwP
And cutting them off is the easy, cheap and obvious fix.

Before you take it in next time, borrow a small angle grinder {though any driveway mechanic should already have one - VERY HANDY} buy a cutting disc for it.

Spray paint the thread/ lock nut area, unscrew the outers and cut about an inch off each side. You are removing threads you never will use.
 
1 - 6 of 6 Posts
Top