TCCoA Forums banner

1 - 7 of 7 Posts

·
Super Moderator
Joined
·
7,651 Posts
I'm not 100% sure on the 3.8, but on the V8 cars, it is on the passenger side under the wiper cowl area.
 

·
Registered
Joined
·
134 Posts
if there is no ground from the engine to the firewall, or any other places for that matter, it is a wise idea to add one. in fact EVEN if there is a ground, it is wise to add another one. you can pick up any good conductive spot where you get good metal to metal contact, and run to any spot on the chassis again where you get good metal to metal contact. what i have done on may cars is ground the battery cable to the block, like the factory did, and the run a ground from the battery terminal to the chassis, again like the factory did in many cases, as well as a ground strap from the back of the engine to the firewall. dont be afraid to have three or four ground straps either, remember of the top ten electrical problem causes, the first four are bad grounds.
 

·
Registered
Joined
·
161 Posts
Discussion Starter #4
I'm not 100% sure on the 3.8, but on the V8 cars, it is on the passenger side under the wiper cowl area.
I don't remember seeing one in this area - I know I have the ground strap from body to hood area there.

I'm also curious if the ground strap might be missing (if anyone had a photo that would be great)
 

·
Registered
Joined
·
161 Posts
Discussion Starter #5
if there is no ground from the engine to the firewall, or any other places for that matter, it is a wise idea to add one. in fact EVEN if there is a ground, it is wise to add another one. you can pick up any good conductive spot where you get good metal to metal contact, and run to any spot on the chassis again where you get good metal to metal contact. what i have done on may cars is ground the battery cable to the block, like the factory did, and the run a ground from the battery terminal to the chassis, again like the factory did in many cases, as well as a ground strap from the back of the engine to the firewall. dont be afraid to have three or four ground straps either, remember of the top ten electrical problem causes, the first four are bad grounds.
Always good information rbohm.

I have a #2 from battery to header, #0 from battery to block. I will have to find a strap, or a couple of #0 lugs.

I was primarily curious on the "factory" way to see if it was even still there (or missing/damaged/etc)
 

·
Registered
Joined
·
161 Posts
Discussion Starter #7
the 4.6 cars have it on the RH frame rail ahead of the shock tower. The other end is bolted to the motor mount stud. I don't see why it would be anywhere else on the 3.8 and I don't remember any MN12 having it grounded to the firewall.
That I did see that ground on the electrical diagrams.
 
1 - 7 of 7 Posts
Top