TCCoA Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
In the mornings when I start the Tbird it wont stay running unless I hold the accelerator part way down. if I take my foot off the car stops. after a few miles driving, the rpm's kick in all at once. At stop lights I have to hold the brake and the gas to keep the car running, but this goes away after a few miles of driving.

What I have done so far,; ford dealership cleaned the tbody,replaced injectors,and fuel rails, boch plat 4 plugs, wires, mobil 1 oil, merc v tranny fluid, air cleaner, pvc valve, MAF sensor, and the speed snesor on the tranny. any ideas?
-Tracey In VA
 

·
Registered
Joined
·
798 Posts
That sounds kinda like what my Cougar did. 95 XR7 kept dying at starts or stops all the time, and mine was the IAC Valve. (It may be worth replacing for the mere 46.99 or so.)

That's my guess, but what do I know. :p
 

·
Registered
Joined
·
490 Posts
Sounds like your Idle Air Control valve (I.A.C.) is either dirty or bad. Your i.a.c. is a valve that opens when the throttle body is closed to allow enough air into the motor to idle properly. When you open the throttle body the valve closes... Yours is either gummed up and sticking or is bad and needs replacement...
Erik
 

·
Registered
Joined
·
798 Posts
Eric420 said:
Sounds like your Idle Air Control valve (I.A.C.) is either dirty or bad. Your i.a.c. is a valve that opens when the throttle body is closed to allow enough air into the motor to idle properly. When you open the throttle body the valve closes... Yours is either gummed up and sticking or is bad and needs replacement...
Erik
Yeah, I have one if you want to see what they look like. I'll also show you the carbon build up in side.
 
1 - 4 of 4 Posts
Top