TCCoA Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
53 Posts
Discussion Starter #1
I need some help I am re-falling in love with my T-Bird and I have been taken in as an apprentice to a mechanic but I need some help. I am going to be leaving on a trip to Richmond tomorrow (24th) and I think I have a bad tank of gas, the CHECK ENGINE light comes on, then will turn off after i have stopped or reached a lower speed. I am not sure if the bad stuff burned off yet but the car will kind of "lurch" when the gas is applied in a medium dose (above twenty and below 55mph). I was running late this morning and I was doing between 40 and 65mph right off the bat (no warming up), could I have damaged the engine? Could it be a short, do I need O2 sensors (I have a K&N filter in it, but it just started this today and I have not driven it really since I have got the gas in it, its been sitting for about two days), or is there a short in the electronics? Oil pressure is good, so is the tempreture and battery is good.

help and its good to be back, at least the T-Bird is easy and cheap to fix, doesn't look half bad either;-)!

Jesse
 

·
Confirmed V6 Nut
Joined
·
2,261 Posts
Jesse,

Try a bottle of dry gas or petroleum distillate octane booster.

If your O2s are gone, there will be codes a code reader would find.
 

·
Registered
Joined
·
448 Posts
I've been trying to figure this out for the last 6 months or so my bird does exactly the same thing and I too run it hard (85-ish on a backroad) without warming when running late, hehe.

If you figure it out lemme know. I don't think it's bad gas.

My temps and bat are also good. I've been thinking it's a short or unprofessionally loose wiring or something. Doubt it's actually a short though, that would be a serious mess up.

I got new 02 sensors (Bosch), didn't work so that ain't it.

The difference here is my engine light stays on even when I'm running slow. And it continues to stay on even days later, then turns off. My ABS deactivates randomly sometimes.

I still love this pathetically slow car. I wouldn't trade it for a Jag.
 

·
Confirmed V6 Nut
Joined
·
2,261 Posts
Guys,

When I got my 97 after sitting on a car lot for a while, (They were taking it to the car auction if I didn't buy it.) I had codes showing up that wouldn't go away. I had the code for too rich of a fuel mix. Both my MAF and IAC were bad. I've replaced both and no more check engine lights.
 
1 - 4 of 4 Posts
Top