TCCoA Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
74 Posts
Discussion Starter #1
My idle is raised to 1500 rpm, and im hurtin my trani everytime i put it in gear, also while im driving (30-40+mph), i can literally take my foot off the gas pedal and watch as my rpms slowly raise making me gain speed. I tried fixing it twice, EGR replaced and some oxygen something sensor replaced, even changing the gas back to premium hasn't worked. So im at a loss...someone help please??!
 

·
Registered
Joined
·
2,662 Posts
Maybe the IAC is fubared?

Jay
 

·
Registered
Joined
·
74 Posts
Discussion Starter #4
ok good to know...the IAC is what? and where??
 

·
Registered
Joined
·
10 Posts
Try lubing the throttle cable or adjusting it. Sometimes they stick and it could cause the idle to be high. Try easiet things before buying parts
 

·
Registered
Joined
·
96 Posts
Try lubing the throttle cable or adjusting it. Sometimes they stick and it could cause the idle to be high. Try easiet things before buying parts
Same problem here, except mine was on the highway, I'd let off and watch my speed double, kinda reminded me of the movie "Christine"
 

·
Registered
Joined
·
1,100 Posts
Same problem here, except mine was on the highway, I'd let off and watch my speed double, kinda reminded me of the movie "Christine"
That's funny but at the same time it's not...

I have actually been dealing with a similar problem, but mine just surges like crazy when I am in gear and stopped.

But I can't help you there :confused:
 

·
Registered
Joined
·
510 Posts
My car did the same thing after I changed the spark plugs. I traced the problem to a broken vacuum line. Those rigid plastic lines break very easily.
 

·
Registered
Joined
·
74 Posts
Discussion Starter #11
ok kool, thanks eveyone, i havent had the time to check up on the forum until today, but i'll check the vacuum lines, the IAC valve, and lube/adjust the throttle cable (first) i hope this works thanks alot!
 

·
Registered
Joined
·
24 Posts
My problem was solved with a new IAC valve, check out my "high idle" thread in 5.0 engine section - maybe your symptoms are the same as mine were.
 

·
Registered
Joined
·
52 Posts
IAC or vacuum leak. vacuum leak can be a pain to track down sometimes too. with the hood up and a/c off, sometimes you can hear it if you hear a hissing sound. you can also spray around the intake area with carb cleaner or ether. if you get nothing, cool. otherwise, you have just located your vacuum leak.
 
1 - 13 of 13 Posts
Top