TCCoA Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
So I was given a 1995 tbird 4.6l six months ago and the previous owner said it has always had a misfire under load at low rpms and does it ever. I proceed to do all the normal stuff: plugs, wires, coil packs, fuel filters but the misfire wont go away. I go out and buy a code reader, it throws a P0304 code cylinder four. So, I check if the injector is getting power, it is, they all are. I then build a jig to bench test the injectors, they all work properly and are clean. In a last effort I change the intake gaskets and inspect the valve train, nothing i don't see any changes. Is this a common problem with tbirds?
 

·
Super Moderator
Joined
·
10,651 Posts
The common problem for 94-95 cars is the EEC sticking an injector open, running gas out the tailpipe.

Check it with injector lights, and see if one isn't working.
 

·
Registered
Joined
·
1,864 Posts
What did the spark plug look like on that cylinder?

Al
 

·
Super Moderator
Joined
·
10,651 Posts
Was it wet with gas or oil?

You need three things to fire properly:

Air
Fuel
Spark

As the other plug is firing, this one is likely firing as well. Or it's shorted to ground, that will still run the other plug.

If you checked the injectors, and they work, and the injector test light says it's working, then air is the last thing to check.

Either there's a follower off one of #4's valves, or a valve is stuck open or something.
You need to yank the valvecover and look.
 

·
Premium Member
Joined
·
1,371 Posts
theres a hose under the intake that goes from the left to the right, sometimes it gets soft and sucks closed but ends up splinting on one end and causing vacuum leak. check that first before throwing more money at it.
 

·
Registered
Joined
·
440 Posts
Check your vacuum hoses. When I first got my car it had a P0304 and another misfire code. I checked the vacuum lines and the vacuum line/elbow from behind the plenum was badly cracked. Replacing it fixed that problem.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #10
I got a new ecu and the car ran great but now i have a p1405 code and it wont go above 2000 rpm and 30km\h please help
 
1 - 11 of 11 Posts
Top