TCCoA Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
104 Posts
Discussion Starter #1
Was hit the 15th. Car drove fine, some front end damage. The radiator fan fuse blew and has a lot of resistance when i try to turn it manually im guessing its damaged some where, and the fuse blew when it kept trying to move.

basically it has a rough idle at times when parked [sounds as if about to stall, then picks up and runs fine when gas pedal is pressed]

Same when driving, all is fine then sometimes rough idle at stop sign and surging/stumbling when i accelerate for a bit then it vanishes after past 10-15 mph or so.

IAC is fine as well as air filter. Any other quick ideas to check?

95 T bird
3.8 non sc
 

·
Registered
Joined
·
104 Posts
Discussion Starter #2
Noticed while driving that when i accelerate from a stop slowly, this hesitation/lurching doesnt happen nearly as often or at all...

What may be causing it to do so when i accelerate fast vs slow?
 

·
Registered
Joined
·
104 Posts
Discussion Starter #4
If it was hit on Pass side,maybe the canister and Vac lines were damaged?
front drivers side right by bumper area, radiator was shifted out of place, luckily no leaks bought a new unit and works.

also when i turn even if i accelerate slow it does the chugging/hesitation thing sometimes..
 

·
Registered
Joined
·
104 Posts
Discussion Starter #5
So ran car with MAF sensor on and off runs the same still rough idle, hesitation during acceleration, checked ohms at the IAC got 11, which is in range of 7-13 according to most sites. MAF looked good by looking at it, can try cleaning booth, other than that any ideas?
 

·
Registered
Joined
·
104 Posts
Discussion Starter #6
cleaned MAF and checked PCV tubing or w/e it is called didnt notice any difference when i took it off and plugged it.

running out of ideas to test before i just scrap the car...?
 
1 - 6 of 6 Posts
Top