TCCoA Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
300 Posts
Discussion Starter #1
Okay I have a 1990 bird and it seems every winter my temp goes hot cold when it feels like it wants to and no heat....so earlier today it was 1* outside(farily warm for december in canada) temp stayed 1/4 like usually with hot heat .....later on at night like -10* or so and temp stayed 3/4 to Hot and no heat......

Also sometimes when I start it and let it warm up i go down the road and when i give it gas it bogs down to like 400 RPM then back up and so on then its fine? and if i give it good and im going slow it almost stalls????? only sometime just after started like 5 min or so?
 

·
Registered
Joined
·
203 Posts
try changin the thermostat and coolant temp. sensor. i know sometimes a bad coolant temp sensor can cause idle and acceleration issues. hope this helps!
-mike-
 

·
Registered
Joined
·
300 Posts
Discussion Starter #3
actually i changed the cool. temp sence like 5000 K ago. and the thermostat and water pump a year ago but still worth a try unless someone else has ideas?
 

·
Moderator, Iowa Chapter Director, Uber Luber, TCCo
Joined
·
8,978 Posts
i change my thermostat every year just for peace of mind.
-Thomas
 

·
Registered
Joined
·
1,921 Posts
A simple test for your thermostat. boil a pot of water on the stove and toss it in to see if it opens, I ALWAYS test new ones before I install them also!
 

·
Registered
Joined
·
300 Posts
Discussion Starter #6
thanks rancherlee I will try that this week when i find time since i wont be driving much at all and close to christmas and my 19 bday :D (canadian drinking age......lol)
 
1 - 6 of 6 Posts
Top