TCCoA Forums banner

1 - 20 of 22 Posts

·
Motorboatin' SOB, Headlight Cleaning Guru
Joined
·
6,910 Posts
Discussion Starter #1
im trying to remove a fuse in the box under the hood. this particular fuse is held down by bolts. there are three fuse compartments next to each other. my blower motor fuse may be out and this is the one that i am trying to remove. its the only fuse among the three compartments, in the middle. i tried unscrewing the one bolt on the firewall side of the compartment, and i ended up cracking part of the compartment that slides up and down. before i go out and try to remove the middle bolt from the other side of the compartment, does anyone have any tips on removing the bolts to access this fuse?
 

·
Chief of Warranty Police
Joined
·
1,492 Posts
I think I know what you're talking about, but I can't be sure without a picture...can you put one up?
 

·
Motorboatin' SOB, Headlight Cleaning Guru
Joined
·
6,910 Posts
Discussion Starter #3
i can describe which fuses they are. if you are standing in front of the engine, these fuses are in the upper left corner of the fuse box. the compartment that they are in slides up after a clip is released, but it doesnt slide up very far. there are three bolts that hold the fuses in place, but i only have one fuse in the middle, and i need to remove and check this fuse.
 

·
Motorboatin' SOB, Headlight Cleaning Guru
Joined
·
6,910 Posts
Discussion Starter #6
mine has 3 side by side, with a fuse for the blower motor in the middle. i got the screws out, but how can you tell if the fuse is bad? there is a clear "roof" on the fuse; does a cracked/split metal piece inside indicate a blown fuse? mine looks fine.

also, will a bad blower motor fuse cause an a/c head unit in the dash to not receive any power?
 

·
Jedi Master
Joined
·
3,647 Posts
to check the fuse you'll need to pry off the plastic cover of it carefully if you can't see if the fuse is broken
you're talking about fuse "J" right the 80 amp one...
to be honest i don't know if it does or not, check the fuse out then let us know if its blown or not....
 

·
Motorboatin' SOB, Headlight Cleaning Guru
Joined
·
6,910 Posts
Discussion Starter #8
yeah, i am referring to the "J" 80 amp fuse. the metal piece under that clear cover looks fine. does the fuse panel under the driver side kick panel contain a fuse that provides power to the a/c unit?
 

·
Motorboatin' SOB, Headlight Cleaning Guru
Joined
·
6,910 Posts
Discussion Starter #10
the 30 amp fuse is good. do i need to completely remove the J fuse to see if its bad, or will looking into the clear cover tell if it is bad?
 

·
Registered
Joined
·
215 Posts
Fuse Box

Yes I have a 1990 Cougar XR7 and my rear defroster is not working. I need too check the high current fuse under the dash but I cannot find a diagraham of it because I don't have an owners manual could someone please tell me which one it is???? Thanks!!!!!!
 

·
Registered
Joined
·
2,233 Posts
Big Mike:
I have a wiring diagram at home. What, exactly, is not getting power? Just the blower motor? Or do you have the auto climate control? Let me know, and I'll trace it out tonight.

I'll try to remember to do the rear defrost also.
 

·
Motorboatin' SOB, Headlight Cleaning Guru
Joined
·
6,910 Posts
Discussion Starter #15
tobey, the a/c unit in the dash is not getting power, except for the lights that come on when you flick on the headlights. i dont know if my blower motor is bad. pushing buttons on the a/c unit does nothing, but i do hear that pshhh sound.
 

·
Registered
Joined
·
215 Posts
The Rear Defogger

When I push the button and it lights up,but the rear defogger doesnt defog the window.I think maybe the High Voltage fuse under the hood might be the problem.I just dont know which one it is.I have the book on 95 T-Birds,but not on a 90 Cougar XR-7 SC.Thanx...Tony
 

·
Registered
Joined
·
111 Posts
Mike i looked in my repair manual and on my ford service cd.
On the cd is a great diagram , but i can't kopie it from the cd.(don't know why).

On the primary junktionblok is a fuse of 15A that is also going to you AC panel.
The primairy junktionblok is on the driverside to left of the steeringcolum.

Here are some hints from the repair manual :
1* Blown fuse.
2* Loose or bad connection.
3* Defective ground.
4* Faulty switch.
5* Faulty motor.
6* Faulty resistors.
 

·
Registered
Joined
·
2,233 Posts
1 BAD T said:
When I push the button and it lights up,but the rear defogger doesnt defog the window.I think maybe the High Voltage fuse under the hood might be the problem.I just dont know which one it is.I have the book on 95 T-Birds,but not on a 90 Cougar XR-7 SC.Thanx...Tony
You're on the right track. The switch on the dash activates a high-amp relay. It gets power from a 40 amp fuse in the Power Distribution Box. My manual doesn't detail how that box is laid out, but it shouldn't be hard to check all the 40 amp fuses. A pair of needle nose pliers will pull those suckers right out.
 

·
Registered
Joined
·
2,233 Posts
big mike said:
tobey, the a/c unit in the dash is not getting power, except for the lights that come on when you flick on the headlights. i dont know if my blower motor is bad. pushing buttons on the a/c unit does nothing, but i do hear that pshhh sound.
Mike:
My manual for the older cars doesn't have the diagrams for the a/c circuit. Sorry, I thought it did.

I have the factory manual for my '97. PM your email address, and I'll send you all the AC wiring diagrams for it. I'm doubtful they'll help, but it's worth a try.

5.0HO: The only way I know of to share the pictures from the CD is to hit "PrintScreen", paste it into "Paint" or some other graphics program, and save it as a JPG file. It took 6 times to get all the '97 AC diagrams. Mike will have to print them, and tape them together or something.
 

·
Registered
Joined
·
111 Posts
Thanks Tobey , i learned something today.

Big Mike here is the diagram :


If you need some more just let me know.
 
1 - 20 of 22 Posts
Top