TCCoA Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter #1
i have a 95 4.6 and im having a problem with the check engine light. I had the codes read and they said it was an emissions problem more specific the EGR valve. he told me to clean it. would i be better of replacing it?
 

·
Registered
Joined
·
2,514 Posts
Do you know exactly what the code was?? The 94-95s are a bear to replace. There behind the motor by the firewall.

-Matt-
 

·
MAMN12 Posse Member
Joined
·
2,903 Posts
P0402? I think that's it....anyway...Excess EGR Flow? That's the one I had, and I was told to replace this sensor on the back of the engine. I asked another knowledgeable person and they said that as long as the car runs/idles fine don't worry about it. So I didn't...it was on for at least a year before I pulled the engine.
 

·
Registered
Joined
·
23 Posts
Discussion Starter #6
also guys my low coolant light in the information center will not go off what do i do about that i have checked it everyday and its levels are perfectly fine
 

·
Trumpeter Extraordinaire
Joined
·
2,916 Posts
T_Byrd87 said:
also guys my low coolant light in the information center will not go off what do i do about that i have checked it everyday and its levels are perfectly fine
A short test from the 1994 Service Manual:

Pinpoint Tests

PINPOINT TEST C: LOW COOLANT INDICATOR ON WHEN COOLANT IS NOT LOW

C1 MEASURE RESISTANCE

Disconnect Indicator Lamp Module from body harness.

Measure resistance between Circuit 794 (LB) on the harness connector and ground.

Is resistance less that 1000 ohms?

Yes
SERVICE or REPLACE wiring harness or connectors.

No
REPLACE ILM.


How clean is the sensor? You may want to check if there's any build-up on the sensor inside the reservoir.....(just a thought). My car experienced an erroneous Low Coolant a few years back. I decided to flush the coolant system, removed the reservoir, and cleaned it thoroughly, as there was some build-up in it. No more erroneous light.
 

·
Registered
Joined
·
523 Posts
my coolant light was staying on i ran some power flush through it and filled it to normal level and it turned off
 
1 - 9 of 9 Posts
Top