TCCoA Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
so two things have happened to my bird and i dont even know where to begin.

1st - last night my gas guage jumps from half tank to full as im driving... so this morning i took the guage cluster apart to make sure the anti slosh board was still in place, and it was. so I think that maybe the float might have gotten stuck so i took the bird down to pilot to fill her all the way up thinking this would work the float un-stuck. and as im filling up gas starts gushing out from underneath my car so i hurry and stop the gas and look under there and its just dripping all over the place.

sooo i hook up my superchips programmer that i just bought from dunesgirl (thanks again for that) and it gave me a few codes. the important one is p0231(P0231-Fuel Pump secondary circuit low)

so i dont even know where to start on this new and very aggravating problem.. i dont think the fuel pump can be going out because its only about three months old.

what do you guys think?
 

·
Registered
Joined
·
1,488 Posts
Damn.. That sucks lol
 

·
Premium Member
Joined
·
72 Posts
Check the fuel pump cutoff switch(rollover switch) , that can cause a 0231 code , as well as a bad fuel pump relay , or faulty fuel pump wiring(a short).
As for the fuel running out when you filled....check the filler hose for a leak maybe. :)
Larry
 

·
Registered
Joined
·
18 Posts
Discussion Starter #4
alright ill check that out. and gas has been leaking all day. i am now at half tank and i filled up this morning. like when ever i take corners and stuff. when i park there are little drops of fuel that have run off from the top of the tank somewhere. maybe the o ring around the fuel pump wasnt put on correctly?
 

·
Premium Member
Joined
·
72 Posts
Sounds more like the center fuel line port O ring was left out on the pump housing. Were new clips installed on new pump housing? It could cause a siphon effect if one of your lines is leaking. Good point on the O ring around the pump also. The only thing that sucks is you gotta pull everything to check it. :(
You might try to put some air pressure to the tank and see if you can hear it. Just don't put to much in it. It doesn't take much to find a leak.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #6
sorry as my forum status states i am a "newbie" haha what exactly is a center line port o ring? and by clips do you mean the locking ring on top of the tank that secures the fuel pump? i believe a new oring was installed under the locking ring but i am not sure if the locking ring is new. and yeah pulling everything isnt fun but i didnt it with the fuel pump so im kinda used to how everything goes.
 

·
Premium Member
Joined
·
72 Posts
Dang there are only 2 lines coming from your pump right? There are plastic clips that are kinda U shaped that hold the lines to the pump assembly. If they are broke or a line is bad at the connection point you could be loosing fuel there. The lines don't take well to kinking. I had that issue once.
I would think that if the O ring around the assembly was leaking it would quit way before a half of a tank of fuel was lost. Did you have any prob with the lock ring?
I hate to say it but you better pull the tank and check all fittings.
P.S.: Do a fuel pressure test and make sure it holds the right pressure. I think it's at around 40psi but you better check with the 4.6 gurus:)
 

·
Registered
Joined
·
18 Posts
Discussion Starter #8
yeah just two lines. and no actually the locking ring went on very easily. the first try actually. usually it takes me a couple tries to get those things on. i just dont see how those things could kink under there.. hmm ill check it out though. its gunna be a while cause my school is on break right now we wont be back into the shop for a couple weeks so imma just try to keep my fuel level down so im not spillin all over town. and ill do some research on the correct psi for the fuel system.. just kinda sucks that i wont have the correct tools to do a pressure test until im back in shop. so im kind of at a stand still here.
 

·
Registered
Joined
·
892 Posts
yeah just two lines. and no actually the locking ring went on very easily. the first try actually. usually it takes me a couple tries to get those things on. i just dont see how those things could kink under there.. hmm ill check it out though. its gunna be a while cause my school is on break right now we wont be back into the shop for a couple weeks so imma just try to keep my fuel level down so im not spillin all over town. and ill do some research on the correct psi for the fuel system.. just kinda sucks that i wont have the correct tools to do a pressure test until im back in shop. so im kind of at a stand still here.

Correct Ford fuel PSI is 39.15lbs. I have run 55lbs on some Mustangs to defeat the PCU corrective abilities with no problem. Missed something bud.

Brad
 
1 - 9 of 9 Posts
Top