TCCoA Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
61 Posts
Discussion Starter #1
So I have at least one coolant leak coming from somewhere in my engine bay but due to the amount and the place where the fluid's ending up on the ground, I'm consulting the experts before going any further.

This first image was taken over the engine bay from the driver's side. The red arrow I put in is pointing to a dark area right in front of the thermostat. The area's dark because it's damp from leaked coolant and, if you look closely, you can see a little bit of green from fresh coolant in that pocket. I last flushed the radiator and replaced the thermostat a few months ago. The last time before that was maybe two years before. To be honest, I've seen trace amounts of fluid appear in this little pocket before, but since there's be no noticeable effect on my fluid levels overall, I never thought much of it.



This next picture is what I'm more concerned about. As you can see, I took this picture from the passenger side and the fluid is right under the middle of the car, slightly behind the engine.



I put my camera under the passenger side of the car pointing upward and took this next picture. You can see part of the exhaust is wet from coolant.



This is the first time I've seen this volume of fluid coming from this area of the car. I first noticed it yesterday after finishing washing my car. I moved the car and there it was, a small puddle about the size of the one pictured above. The last time the car had been driven at the time was about two hours before, so the engine was fairly cool when I noticed the puddle. I drove the car again for about ten minutes shortly after noticing the puddle to warm it up and see if I could notice anything. When I got back there was no obvious additional leaking. I checked a couple hours later and still there was nothing. It's been close to 24 hours since I last drove the car and the fluid that's there now is all that leaked over that time. In fact, when I took the pictures I could see very tiny drops falling periodically. In spite of this, the fluid levels in both the radiator and the resevoir are where they should be. So whatever kind of leak this is, it doesn't appear to be very large right now. I did smell a minor odor of coolant inside the car when I drove it last, but I also detected this in the engine bay, so I don't know if maybe the heat of the engine spread it around (since fluid has leaked onto the exhaust). I suspect maybe the heater core (which is original) but I don't know how to verify this. So does anyone have any thoughts? Thanks in advance.

Also, there's about 142,500 original miles on the engine (no headgasket failure) and it's a '94 Thunderbird.
 

·
Registered
Joined
·
3,781 Posts
maybe a freeze plug for it to be that far back. also make sure the t-stat bolt are tight. mine used to leak everytime i took out the t-stat so re torque them first. also i know my heater hose (i think the return, the hard line that has a bracket on the manifold) has a small slow leak around the clamp that ford for some reason riveted to the hose. look there also, but that too much water for that i think. check both rad hoses, and also look at the back of the timing cover where it meets the engine and see if there is a leak there. mine leaked there before and i had to put a new timing cover gasket in. if none of this is the problem, then i have no idea.
 

·
Registered
Joined
·
34 Posts
i wld say it is ur water pump and or ur thermostat.... i had a major water leak on my car which didnt show up to much till it was warm..and no body cld find the leak..any who ..it turned out to be the water pump.... doesnt look like the thermostat on ur car has been touched any time to soon either..time to take care of that any how
 

·
Registered
Joined
·
61 Posts
Discussion Starter #4
Well, I put some Bar's Heavy Duty Stop Leak in the radiator yesterday and it looks like problem solved for the time being. The driveway's dry and I can't see any new coolant leaking in the engine bay. Hopefully it holds up for a while. I really don't want to take the time to jump through hoops trying to figure out what the core of the problem is.
 

·
Registered
Joined
·
43 Posts
Pressure test the system. But you'll need a pressure tester :( Than you can find the location of the leak without guessing.
 

·
Registered
Joined
·
466 Posts
cover up the electronics and pressure wash the engine bay. Let it dry then drive it around the block and park it for the night....it will be easy to see where it is coming from the next day.
 

·
Registered
Joined
·
466 Posts
Well, I put some Bar's Heavy Duty Stop Leak in the radiator yesterday and it looks like problem solved for the time being. The driveway's dry and I can't see any new coolant leaking in the engine bay. Hopefully it holds up for a while. I really don't want to take the time to jump through hoops trying to figure out what the core of the problem is.


BAD IDEA.....your HG's will not like you soon. Like I said in my last post, pressure wash the motor and you will see where the coolant is comming from. My guess is the thermostat housing.
 

·
Registered
Joined
·
105 Posts
This next picture is what I'm more concerned about. As you can see, I took this picture from the passenger side and the fluid is right under the middle of the car, slightly behind the engine.
Did you figure out where this leak was coming from? I have a 91 Cougar that is leaking in the same place - the passenger side - mid engine. I know that it is not a thermostat, water pump, heater hose, or heater core.
 

·
Registered
Joined
·
25 Posts
find your leak?

did you ever find your leak?I just noticed a leak on my 95 3.8 and it appears it was a loose hose clamp on the hose coming off the bottom of the radiator where it fastens to the water pump causing it to squirt up behind the water pump and pooling up on the lip of the frame crossmember directly below.
 

·
Registered
Joined
·
105 Posts
No, it quit leaking and I have since sold the car. I could never find anything wet besides under the car. I did tighten some hose clamps, that must have been the cause.
 

·
Confirmed V6 Nut
Joined
·
2,261 Posts
Anyone check their intake gaskets? I blew mine out. Also, I had a leak on the intake were one of the hoses attached to it. Between the two fixes, I've stopped losing coolant.
 
1 - 13 of 13 Posts
Top