TCCoA Forums banner
1 - 11 of 11 Posts

·
Registered
Joined
·
121 Posts
Discussion Starter · #1 ·
i was gettin no fuel to the motor so i put a new pump in its not working...i checked the fuel pump shut off switch and its pressed down...ive ran outta idea any ideas on wat i do???because im stuck and dont know wat to do from here...
thanks austin
 

·
Premium Member
Joined
·
2,725 Posts
if i recall correctly there are only a couple of items in the circuit. You have a fuse in your high current fuse box which feeds the IRCM which in turn feeds the inertia switch which feeds the pump. Obviously check the fuse first and go from there.
 

·
Premium Member
Joined
·
557 Posts
can u hear the pump turn on? u didnt say.
 

·
Registered
Joined
·
5,978 Posts
ccrm is my bet it includes the fuel pump relay among others
 

·
Premium Member
Joined
·
557 Posts
ya thats what i was going to say if he said it wasnt turning on.
 

·
Registered
Joined
·
121 Posts
Discussion Starter · #9 ·
so do i take it to ford and get a new one or how do i get it fixed and wat kinda price?
 

·
Premium Member
Joined
·
557 Posts
you can test the wires coming out. and its like one screw to take it off.. i remember when i pluged my new one in it blew a fuse.. and then i went to turn the pump on and it didnt. after i tested so many wires and was for sure that that was it. ha i was soooooo mad. but then i checked fuses and that was it. mine was $135.60 from ford,maybe try junkyards. idno if u would want one from there or the prices your yards want you to pay.
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top