TCCoA Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
524 Posts
Discussion Starter #1
Ok so I have been having a rough idle and surging below 3k rpm untill vehicle warms up, since my CEL is blown (bulb) I got my car scanned at Auto-tards.

I don't recall the name but it has something to do with the air to fuel mixture causing the rough idle. I also have EGR excessive flow, but I've had that for years now. I've cleaned the channels also.

Recently I did a harsh (thru shrader valve on fuel rail) fuel injection clean.

The car idles rough and it feels like there is a dead cylinder when first cold. Intermittently I get a backfire or hear a LOUD pop from my Intake tube. It goes away within one minute.

When I first start the car it idles fine around 1k rpm. Soon as the IAC adjusts and dips rpm it starts shaking and misfiring away. Then at 1/2 throttle it sounds like a dirty maf would, ect. At WOT the misfire goes away and comes BACK when i let off throttle.

One thing I do notice. The motor makes a "click" noise and the car runs fine after that like almost something is being stuck shut @ 3/4 or below throttle.

I have NO IDEA what to do. Could I have killed an injector? If so, what would diagnosis mechanically for a fuel injector be?

So far I've cleaned my maf, replaced plugs wires, tried another fuel injection clean, checked torque converter (before code was thrown), checked valves (bad guides, burns oil), compression test. Everything check out OK. A long time ago the car had a rough idle and my pops messed with the set screw on the throttle body (this was 3-4 years ago). I dunno if the ATF mixture is incorrect now.

This problem is bugging me pretty bad now, because I was leaning towards fuel injectors untill that code was thrown.

Please help!!!
 

·
02 Explorer Pioneer
Joined
·
2,880 Posts
IT could be any number of things even with the code you got. How old are your plug wires
 

·
Registered
Joined
·
293 Posts
Replace the fuel filter?
 

·
Fry Rice Specialist
Joined
·
4,794 Posts
when will you be up in midland again? if you're up here stop by my place and see what can i do.
 

·
Registered
Joined
·
524 Posts
Discussion Starter #6 (Edited)
Next week. Tuesday and Wensday.

Its very hard to diagnose since it happens only once in the morning and once in the evening.

I'm up for that though. You still working on your engine swap?


EDIT: Also do you have any knowledge of the MAF or IAC?

Do you have any specs signal-wise? Should it be a 5v ref signal constant?

Can I take a ohm reading of the sensor and convert it to hz or g/s? How about for the IAC, does it measure in counts?

I'm not too fond how Ford does their specs of the MAF or IAC. Do you know or have a diagnostic flow chart on these sensors?

I wanna try and capture a volt reading when the problem persists on each sensor.
 

·
Fry Rice Specialist
Joined
·
4,794 Posts
i'm free on wednesday and let me know if you wanna come.

my house just few blocks a way from bone daddy's bbq place on bay city road.
 
1 - 8 of 8 Posts
Top