TCCoA Forums banner

1 - 19 of 19 Posts

·
Registered
Joined
·
342 Posts
Discussion Starter #1
I dd a search and can't find any answers. I have a new pi intake and a 75mm plenum and bbk tb an an 80mm MAF. What am I gonna need for an intake tube?
 

·
Registered
Joined
·
4,407 Posts
Your going to need a 96+ inlet.Or you can buy a CAI for it.
 

·
Registered
Joined
·
3,726 Posts
x2 on the 02 Mustang GT intake (or I THINK 99 if you are using a seperate IAT, it has the provision for it, if you are using an airbox that doesn't have the hole for the IAT). It was a STRUGGLE to get my stock 97 zip tube on the MAF, it wasn't worth it to me.
 

·
Registered
Joined
·
4,407 Posts
Where can I find a CAI.
This is what I have.It fits perfectly but was not the cheapest piece out there.I just got it because it looks pretty.And I needed a bigger inlet for the LMAF.Which the CAI skewed anyway and caused me to run lean.But Lonnie sent me a retune so all is good now.


If I were you I would find a member here with a 96+ inlet tube.They can be found for the price of shipping.I have one now if you need it.And I also have an inlet from an 02 Explorer 4.6 which accepts a 90mm LMAF and will work on your car as well.
 

·
Registered
Joined
·
4,407 Posts

·
Registered
Joined
·
342 Posts
Discussion Starter #10
I got the CAI from supercoupeperformance. How do I get the 80mm maf on the tube comming from the plenum?? The silicone adapter is not big enough? can I just go somewhere and buy one?
 

·
Registered
Joined
·
5,412 Posts
I got the CAI from supercoupeperformance. How do I get the 80mm maf on the tube comming from the plenum?? The silicone adapter is not big enough? can I just go somewhere and buy one?
pepboys usually has a good selection of silicone couplers in many sizes by there ricer stuff
 

·
Registered
Joined
·
5,412 Posts
95xbird whats with the cooling tube on that T fitting on your crossover? Some sort of cooling mod? Any info on that?
 

·
Registered
Joined
·
1,222 Posts
95xbird whats with the cooling tube on that T fitting on your crossover? Some sort of cooling mod? Any info on that?
It looks like he used the explorer PI intake and routed the hose to the back for the heater core.

I used the explorer intake on my swap, but I drilled out the port at back of the manifold where it is on the car intakes, and tapped it with the correct NPT threads (yes, the plastic piece). Then I took the outlet port from the crossover and threaded it into the back of the intake. I've been running it like that without issue for about 2500 miles now.

I figured it was a gamble, but if it worked, I wouldn't have to buy a new intake. If it didn't work, I was back to where I started.

-Rob
 

·
Faster than Porkchop
Joined
·
2,037 Posts
I think he is using a explorer intake with out the heater hose tube in the back .
Thats the work around for that issue .
 

·
Registered
Joined
·
4,407 Posts
Ya I am using the Explorer PI intake on it.I just extended it to the front with a t fitting.Since I had pluged and clamped it in the back and got rid of the fitting.So it looks alittle cleaner under the hood.I don't need my heater anyway.
 

·
Registered
Joined
·
4,407 Posts

·
Registered
Joined
·
4,407 Posts
Are those the silicone connectors that came with the intake or did you go and buy bigger ones?
Those are the ones that came with the kit.It was a real tight fit on the Sensor houseing but it did fit.
 
1 - 19 of 19 Posts
Top