TCCoA Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
290 Posts
Discussion Starter #1
My 95 tbird is having an intermittent starting issue. This morning when I got off work, I went to start it and it just clicked. The battery is fully charged and good and I have a h.o. alternator that I just got so it's good too. The weird thing is, when I turned the steering wheel back and forth, it fired right up. I've also noticed a few times when I shut the car off and open the door, the chime goes off like the key is still in the ignition switch and I'll have to put it back in and turn it on then back off to get it to stop. Any ideas? Key switch or ignition switch? I've never had this problem before. It's a low mileage car so it hasn't been driven much.

Thanks
Mike
 

·
Registered
Joined
·
2,662 Posts
Sounds like the ignition switch is starting to act up to me.

Jay
 

·
Registered
Joined
·
654 Posts
some times I have to hold the key in the start position for a second or two for the starter to engage. No click no nothing, just a pause. It only happens when it's cold. I don't know if it's the ignition switch, factory alarm, or the starter. It's been that way ever since I've had it (7 years) It still does the same stuff, I just got used to it...
 

·
Registered
Joined
·
290 Posts
Discussion Starter #4
Sounds like the ignition switch is starting to act up to me.

Jay
The ignition switch as in the key switch or is there another switch inside the column called the ignition switch like older cars have?

Mike
 

·
Registered
Joined
·
290 Posts
Discussion Starter #5
some times I have to hold the key in the start position for a second or two for the starter to engage. No click no nothing, just a pause. It only happens when it's cold. I don't know if it's the ignition switch, factory alarm, or the starter. It's been that way ever since I've had it (7 years) It still does the same stuff, I just got used to it...
My other tbird did that but this it totally different.

Mike
 
1 - 5 of 5 Posts
Top