TCCoA Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
171 Posts
Discussion Starter #1
I'm relatively new and I haven't experienced a bad transmission before. Sometimes my engine gets loud when switching from 1st to 2nd. The Tachometer will usually read in the 2.5 to 3 range when this happens. Is my trans slipping? Can I get the transmission fluid flushed to help the problem? Or is there even a problem? Any suggestions would help. Thanks in advanced! -Kevin
 

·
Newbie
Joined
·
5,650 Posts
Loud as in the RPMs flare up? If so then it sounds like slippage. If it hasn't been done within the last 30k miles, you should completely drain and refill the trans and torque converter. Do NOT attempt any kind of flush. That will cause more harm than good. If the fluid comes out dark and fullof friction material, your trans is toast. If not, put a new filter and refill it with Mercon V and only Mercon V.
 

·
Registered
Joined
·
171 Posts
Discussion Starter #3
I was afraid of that. I will take it to the shop this weekend and get it checked out. Seeing as I just bought it and it didn't start doing it until yesterday I'm hoping it can be fixed without replacing or rebuilding the transmission. Thanks man.
 

·
Registered
Joined
·
171 Posts
Discussion Starter #4
I appreciate whoever moved this for me. I didn't know where is was supposed to go. I found out I just have a leak in my transmission. Its only going to cost me $200 to fix it. Thanks alot guys!
 

·
Banned
Joined
·
613 Posts
wow thats a nice and cheap fix. i need to rebuild my tranny. 1-2 gears are grinding
 
1 - 5 of 5 Posts
Top