TCCoA Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
48 Posts
Discussion Starter #1
Hello all,

I haven't posted in a while, but I keep up with this site very regularly. Anyway, I hope one of the many gurus on here can help.

I have had several Tbirds, and always upgrade the valve body with the J-mod kit as a first upgrade/maintenance item. My current one is a 97 Sport. I recently bought a tuner from a member here (Superchips 1725) and the tuner and jmod are not cooperating at all. I have tried numerous settings for shift firmness and points, but the 1-2 shift under light throttle just won't act right. It bucks and feels like it wants to shift back and forth between 1st and 2nd a few times before it stays in second. Manually shifting eliminates the problem. I set the program back to stock and the problem went away. So, it must be the tuner program not playing well with the valve body upgrade.

So, I guess my question is, is there a setting I can use that will allow the shifts to happen normally without doing it manually all while keeping the 93 tune downloaded?

I know I might take some heat for using this tuner, but it was cheap, and there are other things that it will let me do that justify having it.

So any help is greatly appreciated.
 

·
Super Moderator
Joined
·
9,303 Posts
Sounds like what would happen if the 1-2 and 2-3 shift curves crossed in the tune...
 

·
Registered
Joined
·
48 Posts
Discussion Starter #3
That is interesting. It shifts fine manually like I said, and it only happens under light throttle. When in Drive, heavy or full throttle will result in a nice firm 1-2 shift. I guess I will try a few more combos before I hang the thing up. :(
 

·
Premium Member
Joined
·
296 Posts
Mine has the same issue with my tuner. I assume we probably have the same tuner. I need to use it temporarily because with my 3.73 rear end I need the tuner to get the shifts close to a decent rpm so I just put it in second at lights and live with it. That will all be fixed with the explorer 4.6 swap and my pro racer software:D. Couldn't find anyway of getting it working right. Mike





Hello all,

I haven't posted in a while, but I keep up with this site very regularly. Anyway, I hope one of the many gurus on here can help.

I have had several Tbirds, and always upgrade the valve body with the J-mod kit as a first upgrade/maintenance item. My current one is a 97 Sport. I recently bought a tuner from a member here (Superchips 1725) and the tuner and jmod are not cooperating at all. I have tried numerous settings for shift firmness and points, but the 1-2 shift under light throttle just won't act right. It bucks and feels like it wants to shift back and forth between 1st and 2nd a few times before it stays in second. Manually shifting eliminates the problem. I set the program back to stock and the problem went away. So, it must be the tuner program not playing well with the valve body upgrade.

So, I guess my question is, is there a setting I can use that will allow the shifts to happen normally without doing it manually all while keeping the 93 tune downloaded?

I know I might take some heat for using this tuner, but it was cheap, and there are other things that it will let me do that justify having it.

So any help is greatly appreciated.
 

·
Registered
Joined
·
48 Posts
Discussion Starter #5
Damn that sucks. I have been doing the 2nd gear starts as well. Its just a minor inconvenience, but it feels almost like I'm riding the clutch in a manual. I'm afraid I might be doing torque converter damage.
 

·
Super Moderator
Joined
·
9,303 Posts
Manual 2nd won't damage the converter, it's just a lower numerical ratio in the trans compared to 1st (by almost a factor of 2, actually).
 
1 - 7 of 7 Posts
Top