TCCoA Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
182 Posts
Discussion Starter #1
I can't get the 2-3 accumulator piston in. I've saturated it in atf and it still won't go up in. I've even taken an 18mm socket with extension and tried to force it in. Has anyone else had this problem? The bottom lip of the piston will go as far up as the surface with where the valvebody bolts up to. I've triple checked the part # with max and it's right. So i'm clueless at this point. PLEASE HELP:(
 

·
Registered
Joined
·
2,662 Posts
I thought the same thing when I did mine last week. I ended up just getting it in there far enough so that the cover with the 3 tabs on it would hold it in, and would still allow the valve body to be bolted up. Mine shifts fine, so I assume that this is correct. Not a tranny expert, but I'm sure that if the way I did it was wrong, that the 2-3 shift would be acting funny, or not doing anything at all. I'm sure someone w/ more knowledge will comment.
 

·
Registered
Joined
·
182 Posts
Discussion Starter #3
See, I can't even get the retainer up into the bore(with piston in). The clips don't even touch it?
 

·
Registered
Joined
·
2,514 Posts
You did take the other piston out right?? :) Just making sure because it sounds like something is stuck in there
 

·
Registered
Joined
·
182 Posts
Discussion Starter #5
Yup, just a bare bore. Do you think that it could be a bad piston. It looks fine, perfectly round, nothing torn, etc. I have blisters on my hand from trying to get it up in there:mad:
 

·
02 Explorer Pioneer
Joined
·
2,880 Posts
If the top part of the piston is not exactly aligned it will apear that the bottom is stuck. Try moving it around trying to seat the top and the rest will follow
 

·
Registered
Joined
·
182 Posts
Discussion Starter #7
Never mind...I'm retarted:D You were right the other piston was still in there. Lack of light:rolleyes: :D anyways thanks for putting up with my ignorance.
 

·
Registered
Joined
·
2,662 Posts
No you're not, just inexperienced. don't feel to bad, I alost did that on the 1-2, lol! Granted I had been up for 13 hours by then so my mind was a little tired. Glad to hear you figured it out. Now go get that car done!! You won't regret it.
 

·
Registered
Joined
·
2,514 Posts
glad to hear you got i figured there had to be something stuck/still in there. I had a little problem with my 1-2 just a little patience and it worked :)
 
1 - 9 of 9 Posts
Top