TCCoA Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
839 Posts
Discussion Starter #1 (Edited)
Hidy hooo! lol, Ok yesterday i dropped off my 97' 4r70w at a tranny shop to do the j-mod for me at the price of $80. I gave him the list and the kit from RobertP.
I went there to pick it up at noon today and he told me he changed out the seperator plates, Installed the new accumulators (even tho he said when he pulled them out, My tranny had the updated accumulators already) Then put in the brown springs for the 1-2 and put everything back together. So i check his work when i arrive and ask if he pulled the spring out of the direct accumulator(2-3 i believe?) and he said "no...you didnt tell me too.. i just changed the accumulator and put the spring and cap back on" I was pretty furious becuz it was right there in the instructions but he said he'd tear it apart again and take the spring out at no charge... however i do have to wait till monday and take another 200mile round trip to the shop to get it:(.
He also changed the EPC soleniod, Pressure regulator valve & speedo gear. The pictures below are what came out of the tranny, Does everything look correct?:confused:


Now the spring i was curious about was this smaller green one... I believe it came out with the old pressure regulator valve.. since the new sonnax one came with a new spring correct?


I'm pry just worrying myself but i'm just making sure. Thanks guyz!
 

·
Registered
Joined
·
2,435 Posts
Looks correct just as said the 2-3 spring is missing
 
1 - 2 of 2 Posts
Top