TCCoA Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
So after 7 plus years in storage the SC is back on the road. Here's the scoop on the engine:

Coy Miller stage one heads and cam
Roller rockers
10% overdrive pulley (getting 11 #'s of boost)
BBK throttle body 70mm
Pro M MAF
Kooks long tubes w upgraded exhaust no catalytic's: no leaks
190 lph fuel pump 38# injectors
373 gears
Pro street tranny 2400 stall
Dave Dalke tune on chip
New plugs gapped at .035
Jacobs wires

I have replaced these sensors: crank, cam, tps as well as iac and the dis module.

So before replacing the dis the engine would backfire thru the exhaust when a steady rpm of 1700 to 2400 was maintained. I changed the dis and the backfire stopped. However the erratic tach started with the new dis at the same rpm range. After additional driving determined that with a vacuum of 18 is when the tack jump/missing starts. If I let off the throttle or give it more gas, it goes away. Checked for vacuum leaks and only found the BBK leaking- a little on the iac side, quite a bit on the cable side. Tried a backyard fix to hold the plastic cap in tighter on the throttle body but that had no change.

Have new wires ordered and thinking about replacing the BBK for one that doesn't leak but not sure if that is the cause of the problem.

Any thoughts?
 

·
Registered
Joined
·
2,472 Posts
Sounds like a vacuum leak best/easiest thing is get a smoke test done on it.

Also watch the balancer and see if it wobbles.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Vacuum Leak

Already mentioned the vacuum leak on the cable side of the throttle body which was revealed during a smoke test. That was the only leak found. I realize all throttle bodys leak but this one put up quite a cloud, about 10 inches or more. I sealed up the cable side as the cap was loose, but with no change. The real question is whether or not that is enough to cause the problem. And why only at 18#'s vacuum? Actually there is one other clue I neglected to mention and that is a pulse of vacuum at idle that changes from 10 to 12 pounds...

So is it the BBK throttle body?
 

·
Registered
Joined
·
23 Posts
Alright, I may be alble to help. Same exact problem on mine, the tach would jump from nothing to engine speed and the car would misfire. there are three possibilities cam sensor is the cheapest but least likly, you already changed the DIS so probably not although most auto parts stores will test it for free if they have a module tester. last is the crankshaft. the harmonic balencer on the supercoupe is notorious for breaking off on the end of the crankshaft.if its starting to go it will probably wobble. DONT DRIVE THE CAR, IT WILL LEAVE YOU STRANDED!!!!! and most likly when it breaks it will take out the crank sensor with it. its a ***** getting the broken bolt out of the crankshaft and the broken balencer off the end.

where are you in wisconsin?
 
1 - 4 of 4 Posts
Top