TCCoA Forums banner

1 - 15 of 15 Posts

·
Registered
Joined
·
103 Posts
Discussion Starter #1
I figure instead of making 10 different threads I would make 1 and list all the problems. Hopefully you guys can help me out with most of these.

- Cruise control doesn't work. No light turns on or anything.

- Low Washer fluid light doesn't turn off. I topped off the fluid.

- The rubber part that you put over the spark plug (don't know the name) sometimes popes out and then it runs crappy. Then I have to push it back in.

- Drivers seat doesn't recline back up. It's always leaning way back.

- Passenger side door doesn't lock or unlock, unless you push the lock down forcefully and pull it up with a plires.

- Passenger side window gets stuck about 3/4 the way going up and down.

- When car is in park and idleing the rpms jump from 500 to 100.

- Windshield wipers only work with high beams on and if the blinker is on they stop working untill blinker is shut off.

- There is a dent in the passenger rear panel. It's not one of those easy pop dents. It's creased in more then 1 spot.

I know there is alot there, but if anyone can help out with these I will really appreciate it. Pictures upon request.

Thanks.
 

·
Super Moderator
Joined
·
9,304 Posts
- Cruise control doesn't work. No light turns on or anything.
Have you had a chance to check the switch at the brake pedal?

- Low Washer fluid light doesn't turn off. I topped off the fluid.
Check the connection to the sensor at the base of the reservoir. Could also be a bad sensor.

- The rubber part that you put over the spark plug (don't know the name) sometimes popes out and then it runs crappy. Then I have to push it back
Get a new set of plugs and wires.

- Passenger side door doesn't lock or unlock, unless you push the lock down forcefully and pull it up with a plires.
Take off the door panel and spray up the latch mechanism and pivot points with WD-40 or PB B'laster. You may also have to replace the lock actuator and clean the crud out of the lock cylinder too if those are frozen up.

- When car is in park and idleing the rpms jump from 500 to 100.
Make sure you're up-to-date on routine maintenance, then clean the MAF and check the TPS and IAC valve.

- Windshield wipers only work with high beams on and if the blinker is on they stop working untill blinker is shut off.
Sounds like the multifunction switch.
 

·
Registered
Joined
·
5,412 Posts
- Low Washer fluid light doesn't turn off. I topped off the fluid.

Tap it lightly to unstick the float inside the tank or disconnect the sensor from the tank and the light will be off forever

- Drivers seat doesn't recline back up. It's always leaning way back.

Take off the plastics or unbolt the seat and I'm willing to be a quarter made its way into the mechanism

- Passenger side door doesn't lock or unlock, unless you push the lock down forcefully and pull it up with a plires.

Sounds like the factory grease in the locking mechanism is gunked up and frozen solid, you can try degreasing it and re-lubing it but more than likely it will need to be replaced.

- Passenger side window gets stuck about 3/4 the way going up and down.

If it slows down when its moving to this point then the bushings (buttons) inside of the motor needs to be replaced, ford uses plastic button bushings in their motors which get old hard and brittle and break causing window problems.

- When car is in park and idleing the rpms jump from 500 to 100.

Sounds like an IAC issue or a vac leak.

- Windshield wipers only work with high beams on and if the blinker is on they stop working untill blinker is shut off.

Sounds like a bad multifunction switch.

- There is a dent in the passenger rear panel. It's not one of those easy pop dents. It's creased in more then 1 spot.

Body shop.
 

·
Registered
Joined
·
103 Posts
Discussion Starter #4
Thanks for the help so far guys. I'll try all of these things tomorrow and update the thread.

Terminator - I looked at that picture you posted in a different thread showing where that switch is (on the brake pedal) and I can't find it. :\
 

·
Super Moderator
Joined
·
9,304 Posts
I'll try to find the schematic in the service manual for you sometime here when I get a chance. It's just kind of hard to get good pics under there in such a tiny space.

On second thought, here's the thread my dad started about the problem we had with the car a year or so ago: http://forums.tccoa.com/showthread.php?t=115111
 

·
Registered
Joined
·
103 Posts
Discussion Starter #6
Update: The low washer fluid light is off now. I just tapped it a few times and it worked.

The rubber part that goes over the spark plug no longer pops out. I just took the plug itself out and put it back in. It was pretty loose. Works fine now.

I looked hard and messed around with alot of things on the brake pedal to fix the cruise, but it's a no go. There is just so many wires and crap under there. It's so confusing compared to my old civic.
 

·
Registered
Joined
·
5,412 Posts
Yay! Lol now look for the spare change in the seat mech
 

·
Registered
Joined
·
103 Posts
Discussion Starter #8
Plan on doing that tonight. I've been busy lately. And im trying to save up for tires becuase every day I have to put air in a couple of my bald tires.
 

·
Registered
Joined
·
654 Posts
- Drivers seat doesn't recline back up. It's always leaning way back.

Take off the plastics
:uppoint:

Bwahah!

I have yet to see a car with the seat plastic intact.

Mine was sticking too. A couple of shots of WD40 did the trick for me.

If anyone knows where I can find a set of said seat plastics just let me know, I think they're extinct...
 

·
Registered
Joined
·
103 Posts
Discussion Starter #10
Can anyone please help me out with this cruise control. I need detailed instructions and pictures. I'm new to thunderbirds so I don't know what to look for.
 

·
Registered
Joined
·
5,412 Posts
:uppoint:

Bwahah!

I have yet to see a car with the seat plastic intact.

Mine was sticking too. A couple of shots of WD40 did the trick for me.

If anyone knows where I can find a set of said seat plastics just let me know, I think they're extinct...
They've been in tact on every tbird I've owned including the faded blue sc seats that were in the 95 I bought from Earl.
 

·
Registered
Joined
·
103 Posts
Discussion Starter #12
Can we please keep this on topic. If you can help me with my cruise then I don't care if you post whore in here all day long.
 

·
Registered
Joined
·
5,412 Posts
Did you check the cruise control fuse under the drivers side dash?
 

·
Registered
Joined
·
103 Posts
Discussion Starter #14
Checked all fuses. Tryed to find that switch on the brake pedal stem but I need a detailed picture. There is just so much stuff under the dash I can't find it.
 

·
Super Moderator
Joined
·
9,304 Posts
Here's the diagram from the factory service manual that shows the mechanism at the upper end of the brake pedal arm. The switch is labeled #2 in the pic:

<img src="http://img3.imageshack.us/img3/5450/img2402t.jpg" width=600/>
 
1 - 15 of 15 Posts
Top