TCCoA Forums banner

1 - 17 of 17 Posts

·
Registered
Joined
·
621 Posts
Discussion Starter #1
I just got a K&N panel filter, and it seems like its a REALLY tight fit compared to the stock filter... I remember reading about a guid on somethin to do with modifying the airbox for that.... does anyone have the link?
 

·
Registered
Joined
·
610 Posts
WaLieN said:
I just got a K&N panel filter, and it seems like its a REALLY tight fit compared to the stock filter... I remember reading about a guid on somethin to do with modifying the airbox for that.... does anyone have the link? [/QUOTE

Here


Southern Pride
Jim Long
 

·
Registered
Joined
·
621 Posts
Discussion Starter #3
Thanks... I guess I was on the right path... I just didn't know if there were any extra things I might have to do. I can't wait for my Holley Power Shot Cleaning Kit to come in, so I can use some MAF friendly oil.
 

·
Registered
Joined
·
610 Posts
WaLieN said:
Thanks... I guess I was on the right path... I just didn't know if there were any extra things I might have to do. I can't wait for my Holley Power Shot Cleaning Kit to come in, so I can use some MAF friendly oil.
There is no thing as MAF friendly oil no matter what any advertising says. :uppoint:

Oil + MAF = Problems

Ask anybody here..

Jim Long
 

·
Registered
Joined
·
222 Posts
Umm Yeah only not so much... :bs:
I've still not had ANY problems with an oiled filter. I had one on my '89 T-Bird, I've got one on my '92 Cat and I have more than 20k on the both of them and niether of the had problems. I really don't understand why people rag on them. It's just :crazy:
 

·
Registered
Joined
·
2,894 Posts
On the oiling topic, DO NOT over oil. The first time I did it, I had to let it (cone) sit and drain with a cloth wrapped around it for a day. You might think that you are not putting enough oil on, but it's easier to put less on first, and add a bit here and there later.

I have had no problems with a dirty MAF sensor from the filter oil. The MAF is bone dry.
 

·
Registered
Joined
·
107 Posts
WaLieN:

Those rims look nice chromed. Where did you get that done? Especially the cap, it's plastic, isn't it?


I haven't had any problem with my MAF because of the K&N filter oil. Anyway, maybe I'll check it out and clean it becuase I'm not getting good mileage (350 km on a full tank).
 

·
Moderator
Joined
·
8,239 Posts
on the oiling topic.

I saw in summit catalog, that accel is making high flow filters called "kool blue" or something like that. Do you know if these filters use an oil or no?

Justin
 

·
Registered
Joined
·
2,894 Posts

·
Registered
Joined
·
610 Posts
Thundercat said:
Umm Yeah only not so much... :bs:
I've still not had ANY problems with an oiled filter. I had one on my '89 T-Bird, I've got one on my '92 Cat and I have more than 20k on the both of them and niether of the had problems. I really don't understand why people rag on them. It's just :crazy:
:uppoint:

I'm not raggin on them. Stating facts was all I was doing. I have a K&N in my 95 4.6 and My 94 SC. I just clean the MAF on a regular basis. But the true cause is the oil, plain and simple. Maybe you ought to research the issue before throwing the BS flag. More often than not MAF related problems are due to oil from a over oiled filter.

Jim Long
 

·
Registered
Joined
·
621 Posts
Discussion Starter #11
Welll, I agree, it is probably the K&N Oil as many car manufacturers are now suing K&N, Ford is one of em, saying that their product has caused a lot of MAF's to fail (cars under warranty).
 

·
Registered
Joined
·
222 Posts
... Research... I was replying to the fact you said "Oil Filter + MAF = Problems". I'm telling you that is not nessicarily the case. The research has been on going with two different MN-12's in my garage. Let's have a :zbeer: on it. :thumbsup:
 

·
Registered
Joined
·
621 Posts
Discussion Starter #13
SilverBird said:
WaLieN:

Those rims look nice chromed. Where did you get that done? Especially the cap, it's plastic, isn't it?


I haven't had any problem with my MAF because of the K&N filter oil. Anyway, maybe I'll check it out and clean it becuase I'm not getting good mileage (350 km on a full tank).
Yeah, your mileage is a little bit off.... try cleaning your maf with some electrical spray and a gentle hand/q-tip. As for my rims, they're stock. They look A LOT better now, because I just polished em. They're stock rims, and the center caps are metal. You can get a pair from the For Sale forum.. some guy is selling them for really cheap.
 

·
Registered
Joined
·
610 Posts
Thundercat said:
... Research... I was replying to the fact you said "Oil Filter + MAF = Problems". I'm telling you that is not nessicarily the case. The research has been on going with two different MN-12's in my garage. Let's have a :zbeer: on it. :thumbsup:
Ok, I forgot that you are more knowing than I.... Whatever...:uppoint:

Go put some oil on the MAF wires and see how it runs... :leftright

Jim Long
 

·
Registered
Joined
·
222 Posts
Blown94SC said:


What a tool you are Thundercat.. When you are wrong don't act like a child. Just deal with it and move on.

Jim Long
What? I paid you a compliment. Can't you accept it gracefully? Jim, you are obviously much better informed on this subject than I. I was being silly but still it was a compliment.
 
1 - 17 of 17 Posts
Top