TCCoA Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
571 Posts
Discussion Starter #1
I decided to drive my bird around today to give it some exercise. I stopped in to get my nails done and was in there for about an hour. I came out and started the car. Immediately the car starts idling really, really rough and when I would give it gas then I would hear the horrible knocking sound. After the car ran for a few seconds, it cleared up and ran alright. My oil was about 3/4 of a quart low so I added a little and drove it home which was about 15 minutes from where I was. I was at home for about a half hour and then I go to get in and start it again and immediately starts idling really hard again. I didn't give it any gas this time. It never died but idled so hard that I could feel it moving from side to side. When I finally gave it gas it started knocking. It's a fairly faint knock, but you can hear it when revving the engine. My dad seems to think it's a rod which for me is really bad but we can't figure out why it's idling really hard. He doesn't seem to think that if it's a rod then it would cause the idle problem. He said that the idle problem could possibly be the fuel pump. We are really stumped as to what is wrong with it. If it is a rod then I will be dropping a new engine in it because I don't think it's worth fixing a 3.8. I did a search but couldn't find what I was looking for or I missed it. Can someone maybe help me out. I really don't want it to be a bad rod because it's getting into show season and we can't afford any large mods because we are trying to buy a house and need all the extra money we can get. Thanks in advance.
 

·
Chapter Director Coordinator
Joined
·
6,253 Posts
knockin equals real bad

yank the plugs, especially the ones at the rear of the motor... its sad to say, but it sounds like were trying to run on coolant... which means headgasket probably took a dump

check the plugs, and respond back...
 

·
Registered
Joined
·
571 Posts
Discussion Starter #3
jamesD said:
knockin equals real bad

yank the plugs, especially the ones at the rear of the motor... its sad to say, but it sounds like were trying to run on coolant... which means headgasket probably took a dump

check the plugs, and respond back...

Head gaskets have already been replaced and it's not overheating. I'll check the plugs tomorrow and report back. Thanks
 

·
Registered
Joined
·
38 Posts
been down that knocking road before, went through 2 motors in less than a year (remanufactured block, installed for $3600CAN), but i think it's cuz of my filter setup.. anyways, mine idles weird sometimes, i was thinking it's the fuel filter. although, mine doesn't idle rough, just gives a little shake once and a while.
 

·
Registered
Joined
·
571 Posts
Discussion Starter #5 (Edited)
Joshua said:
been down that knocking road before, went through 2 motors in less than a year (remanufactured block, installed for $3600CAN), but i think it's cuz of my filter setup.. anyways, mine idles weird sometimes, i was thinking it's the fuel filter. although, mine doesn't idle rough, just gives a little shake once and a while.

Doesn't sound like anything bad. I think it's pretty much a rod in mine. I'm not a bag fan of the 3.8 so I'm thinking of upgrading to a 5.0
 
1 - 5 of 5 Posts
Top